Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Sitemaps relatively easy to setup, follow these instructions...

This discussion is related to the Sitemaps addon.
2»

Comments

  • It is basically becuase routes are normally used to direct to dynamic content rather than generated content. Technically this place does not exist.

    grep is your friend.

  • wow that totally worked. Thanks @x00!
  • Thank you x00. Much appreciated.
  • Thanks a lot x00. it all works because of you. I greatly appreciate it.
  • It does not work in version 2.0.18.1 or at least i cannot get it to work.

  • working fine for me.

    grep is your friend.

  • x00x00 MVP
    edited December 2011

    point to /cache/Sitemaps/sitemaps.index.xml

    it should also display at /sitemaps.index.xml
    either way you can submit it.

    grep is your friend.

  • Doesn't this sitemap rebuild automatically when we create a new thread? I have to manually build the sitemap everyday..

  • Also this sitemap has no style sheet. Like in wordpress, we have sitemap enteries in the form of hyperlinks. Can't we do the same with vanilla?

  • I just noticed that the plugin is creating a duplicated post. Check here

    http://www.environmentabout.com/forum/sitemap.e7a18e007f0e4c11fbea9410f2e408dbb537b118.xml

    I have six posts right now and this plugin us creating post number 1 twice and there is no post for the entry 6.

  • edited January 2012

    I have uploaded installed/activated the sitemap plugin 0.9.1.

    i do not understand this English in the instructions.

    2) Point to /plugin/sitemaps/build in a browser

    vanilla is running in a subfolder.

    i created the cache/sitemaps folder...

    when i try to open http://mywebsite.com/help/sitemap.index.xml i get a

    [Exception][Code]404[/Code][Message]Pagina not found.[/Message][/Exception]

    since there are no settings to configure where should i look for the sitemap?

    Image and video hosting by TinyPic

    Thank you.

    Update..... ok it works.. i had to add a new discussion to get the sitemap generated. I forgot that.

Sign In or Register to comment.