Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2.0.18 (beta 4) and soccial connect issues

edited September 2011 in Vanilla 2.0 - 2.8
I've just make it to download Vanilla beta 4 update and installed.

In beta 2 and older, Facebook connect required allow-url-fopen and my hosting provider turned it off for security reasons. Now its all on curl, give it the setup and when happy tested it gave me "UniqueID is required." something like solved here( ). Bummer, don't know if it will apply and how to for curl one.

Twitter login almost worked. Give it the setup and when happy tested it, popup box stucked after allow twitter at select desired username/password. Clicked connect once, connect twice, connect third and nothing. If older version had a problem with confirmation emails sent at now I didn't even had the chance to get there.

If Facebook was threated with curl only, Open Id required for Google still requires allow-url-fopen.

I wanted to make a QnA website based on Vanilla as it's more appealing and reliable than every wordpress/joomla QnA option and i kinda need those features but i'm not that good to solve it my own. I don't know if it's just my fault or they really have issues.

Sorry about my english if I was hard on your eyes, it's not my native language.

Nothing? Please, I really need those.


  • Options
    I have the same problem with cart. at frist I guessed it was only the Facebook problem as Facebook is being banned in my country, however it turned out all of them ( Facebook, Google, Twitter, Open ID ) doesn't work.
    The funny thing is even I couldn't log in via any of those services but the new accounts have had been registered in the Users List.

    Please look in to this!
    Many thanks :)
  • Options
    Hmm still no answer, Too bad ... or to nothing, I dumped Vanilla
Sign In or Register to comment.