Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.


edited February 2006 in Vanilla 1.0 Help
That's right. and I know it's something completely stupid on my part, but I just can't seem to find the problem. I unpacked Vanilla in a folder, and got a name-based virtual host pointing to it. Now that's working. any test PHP file in there gets parsed correctly. I used the manual install procedure for vanilla. As far as I can tell, I did everything correct. And the big problem is....I don't have an error. the page just returns: <html><body></body></html>. that's it. and that's probably default in firefox. So my guess is that it's returning nothing actually.... It seems like al the "include" stuff in the index.php just doesn't "include" anything, but isn't resulting in an error either. When I intentionally screw up the path in appg/settings.php, I *DO* get an error about files nog being found. So, it seems that the path is not the problem. something with rights then? (altough i'am pretty sure all the files have read permissions at least) Does anyone has a clue? Please tell if I have to post any configuration. any help is greatly appreciated.


  • Did the automatic install process fail too?
  • MarkMark Vanilla Staff
    What version of PHP do you have? What version of MySQL are you using?
  • PHP version: 4.4.0-6 MySQL version: 4.1.13-3 The automatic install feature also failed. I'am not sure what is was, I will try and reproduce it. Maybe it contains a clue.
  • you using the dreamweaver ftp? try re-uploading
  • I work directly on a (test) server. So, not using FTP. but thanx anyway.
  • MarkMark Vanilla Staff
    Well, that's really odd. If I were in your shoes, I'd take the route of echoing test strings in the files until I found where the parsing failed. Start at the top of the index file and make your way through the includes.
  • The automatic installation failed with the same problem on page 3. "Click here to create Vanilla's database tables and proceed to the next step" I get an empty page with no error. I tested if I could use PHP to write to a file (using fwrite) with the same rights as the files used by vanilla, and it worked. I also test to see if a simple echo worked in index.php. That worked, and it triggered an error: This is a test <-- // This is the echo(); Warning: Cannot modify header information - headers already sent by (output started at /srv/www/vhosts/ in /srv/www/vhosts/ on line 14 I also put an echo test in "appg/init_internal.php" and it worked. So includes work...but some of them not? phew. that's weird. and I'am not so sure includes are the problem anymore.... If I remove the echo's, I end up with no output at all again. Maybe it is something with mysql ? (Does index.php make a connection?)
  • MarkMark Vanilla Staff
    I'm thinking it's most likely mysql that is giving you the headaches.

    In, the database connection is made in library/Utility.Database.class.php on lines 103-105:

    $this->Connection = @mysql_connect($Host, $User, $Password); if (!$this->Connection) $Context->ErrorManager->AddError($Context, $this->Name, "OpenConnection", "The connection to the database failed."); if (!mysql_select_db(dbNAME, $this->Connection)) $Context->ErrorManager->AddError($Context, $this->Name, "OpenConnection", "Failed to connect to the '".$Name."' database.");

    The first thing I'd try is echoing something before line 103 to make sure that the parser is getting that far.
    Then I'd also try echoing something after line 105 to make sure it's not getting through this code.

    Then I'd remove any @ symbols from those lines so that any error messages are spit out to the screen. The Vanilla code is meant to capture those errors, but from time to time in various setups it fails to do so.
  • Allright. Both echo before 103 and after 105 are printed. When removing the @ symbol in "@mysql_connect" etc.. i get: Fatal error: Call to undefined function: mysql_connect() in /srv/www/vhosts/ on line 104
  • Make sure you have the library that links php and mysql
  • ithcyithcy New
    edited February 2006
  • or else compile php with mysql support, or install php4-mysql
  • What OS distro are you running?
  • edited February 2006
    I use SuSE 10. Ok it was the mysql module! thanx Mark, ithcy and Bergamot! I thought Yast auto-installed it, but it wasn't installed. But, vanilla doesn't give any error in that direction unless you get rid of the "@" as described by Mark in above post. I really thought I was there, but noooooo. on to the next error: Fatal error: Call to undefined function: session_id() in /srv/www/vhosts/ on line 63 " Session support is enabled in PHP by default.". However, maybe not in SUSE: Will check here again in few minutes. This forum is really helpfull !
  • edited February 2006
    I installed a module for the session function and now it works, but i get yet another error: A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message: Failed to import file "controls/index.php". Affected Elements: Page.Import(); I feel, that I'am missing a lot of php4 extension modules? What extensions do I need besides the "core" module?
  • MarkMark Vanilla Staff
    I had a feeling you were going to run into that problem. Don't know why. There have been a slew of people running into that one lately. The first thing to make sure is that the controls/index.php file is actually there. There is a pretty good discussion about this error here:
  • MarkMark Vanilla Staff
    And there's another one here:
  • The workaround if ($this->SelfUrl == "haliki") $this->SelfUrl = "index.php"; didn't work. :( removing the @ yields: Warning: import(controls/index.php): failed to open stream: No such file or directory in /srv/www/vhosts/ on line 47 Warning: import(): Failed opening 'controls/index.php' for inclusion (include_path='/usr/share/php') in /srv/www/vhosts/ on line 47
  • I'm assuming you replaced 'haliki' with the name of your folder?
    It looks there though asif your paths are wrong in your appg/settings file. Care to paste the relative sections?
  • Note: do NOT post your database password :D
This discussion has been closed.