Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Bootstrap loading as static starting at line 211 instead of loading setup

edited November 2011 in Vanilla 2.0 - 2.8
I've got Vanilla up on dreamhost just lovely.. but I've been trying all day to get a local installation running.

I'm on OSX, MAMP
all required libs are installed (PDO, GD)
Mod Rewrite is on

( Just incase you wonder, I have several other PHP apps running on this installation of MAMP -- so I don't think it's PHP not running. Other pages parse ok.)

I just get a static looking render of:

StartAuthenticator(); $Dispatcher = Gdn::Dispatcher(); $EnabledApplications = Gdn::ApplicationManager()->EnabledApplicationFolders(); $Dispatcher->EnabledApplicationFolders($EnabledApplications); $Dispatcher->PassProperty('EnabledApplications', $EnabledApplications); // 4. Process the request. $Dispatcher->Dispatch(); $Dispatcher->Cleanup(); // 5. Finish profiling and save results to disk, if requested if (defined('PROFILER') && PROFILER) { $xhprof_data = xhprof_disable(); if (is_null($XHPROF_ROOT)) die("Unable to save XHProf data. \$XHPROF_ROOT not defined in index.php"); if (is_null($XHPROF_SERVER_NAME)) die("Unable to save XHProf data. \$XHPROF_SERVER_NAME not defined in index.php"); // // Saving the XHProf run // using the default implementation of iXHProfRuns. // include_once("{$XHPROF_ROOT}/xhprof_lib/utils/xhprof_lib.php"); include_once("{$XHPROF_ROOT}/xhprof_lib/utils/xhprof_runs.php"); $xhprof_runs = new XHProfRuns_Default(); $xhprof_namespace = 'vanilla'; // Save the run under a namespace // // **NOTE**: // By default save_run() will automatically generate a unique // run id for you. [You can override that behavior by passing // a run id (optional arg) to the save_run() method instead.] // $run_id = $xhprof_runs->save_run($xhprof_data, $xhprof_namespace); echo CombinePaths(array("http://{$XHPROF_SERVER_NAME}","/?run={$run_id}&source={$xhprof_namespace}\n")); }

instead of setup. no errors in any logs.

I'm new to the forum and to Vanilla, but I had no trouble setting this up remotely.

Any ideas? I'm desperate to solve this. I can't seem to let it go.



  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    This wouldn't have anything to do with our app. It looks like a problem with your MAMP server. I don't use MAMP so I don't know what it could be though. Maybe give execute permissions to the file?
  • Options
    Hi Todd, Thanks for responding.

    I tried installing it on my localhost using snow leopard's apache server, too, and I get the same thing. It's not a MAMP thing, I don't think.

    I updated the permissions on the app files to 755 and when that didn't work I tried 777 just to see if it'd work. Nada.

    I tried cloning from git rather than using the direct download. I get the same result.

    Have I missed a required package somewhere? I have GD and DPO, but is there a specific configuration of GD that I need? How do I check what version of GD necessary? is this a package I can check from terminal?

    Anybody else out there put this on their localhost / snow leopard successfully that can share their config files or any learnings?

    Thanks again for any help.
  • Options
    TimTim Operations Vanilla Staff
    In technical terms, this happens when the webserver software doesn't recognize the file its given as PHP. It treats it as plaintext and passes it to the browser.

    Does MAMP expose its Apache configs? Can you look for something like AddHandler application/x-httpd-php5 .php? Or maybe for something like LoadModule php5_module libexec/apache2/ ?

    Check that your index.php is named properly. It need to end with ".php" and nothing else.

    What URL are you using to access your site?

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    edited November 2011
    Normally it's easy to find out why it's not recognizing the file.
    I have several other PHP applications running locally, so it's mysterious why this particular route isn't working.

    There must be a conflict somewhere, but I'm not getting any errors at all.

    Everything you noted makes sense, but that's all in order. ---------

    LoadModule php5_module modules/php5.3/ (line288)

    AddType application/x-httpd-php5 .php .phtml (line 292)

    I give up. I'll just work on the remote server and pick it up again later.
    Thank you again for your help, Tim! It's a fine product. I'm sure it's human error on my part somewhere:)

Sign In or Register to comment.