Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

XML stops page render? (huh?)

edited March 2006 in Vanilla 1.0 Help
First off, I'm really looking forward to using Vanilla on my site. Second, I've got an issue which I'm 99% sure is related to my server. Right now, once I copy all files to the server I'm unable to view the README.HTML file until I remove the following line: <?xml version="1.0" encoding="utf-8"?> Once that line is removed, everything renders just fine in readme. Problem is, this line is all over the app, as well. I did a manual install, removed that XML line from various places in the PHP, but had no luck. Since Vanilla works for everyone else, I'm assuming my server (which I don't control) is doing something odd because of the XML line? But I've no idea what... Any suggestions would be appreciated.

Comments

  • lechlech Chicagoland
    My guess is that you have short tags enabled under your php version. This is quite common, if it's a php file, it's going to try to parse everything between <? ... ?>. I don't think there's much you can do at the present moment unless there's a case to fix it. the only suggestion I have for it is if php is attempting to parse, you can replace them with something like this:

    print '<'; print '?xml version="1.0" encoding="utf-8"'; print '?'; print '>';

    it's not pretty, but it should work if it's within the php.
  • Is there a way to turn short tags off with a .ht access file? php_flag short_tags disabled or some such crazy stuff?
  • Apparently if you stick: php_flag short_open_tag Off in a .htaccess file it might do the trick?
  • NickENickE New
    edited February 2006
    Or why not echo('<'.'?blablabla?'.'>');

    EDIT: Nevermind, didn't see the other replies.
  • lechlech Chicagoland
    not in the htaccess file specificly but within one of the php files that's always imported with vanilla. That's also providing that he's able to over-ride any of the ini settings at all.
  • So, adding "php_flag short_open_tag Off" to .htaccees did the trick with rendering the readme.html file... Thanks! I'm still seeing the same behavior (nothing rendered in browser) when I attempt to view the signup.php file. I'm 95.1% sure I'm configured correctly via a manual installation. Any other suggestions? Tried flipping the DEBUG switch to no avail.
  • Ok, fixed. First problem was a trailing backspace on agAPPLICATION_PATH... adding that got me started, but quickly lead to a file include problem... ... Which I'd seen before with Mint... I had to do a php_value include_path "/my/dir/vanilla" .. and I appear to be rolling!
  • I suspect you could have added the necessary to your app path (thats what it's there for) and it would have done the job. Though admittedly i wouldnt even have thought about using a htaccess for that so it was a pretty smart move. Glad you got it working anyway!
This discussion has been closed.