Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Logged in users not jumping to the last-read post.

edited December 2011 in Vanilla 2.0 - 2.8

Running 2.0.18.1. I have confirmed that applications/vanilla/settings/configuration.php has comments autooffset set to true. I have the voting plugin installed and have altered its settings as suggested in another thread, so that the default behaviour is to sort by date inserted. Still, users do not get redirected to the first unread comment when they open a thread.

http://www.vancouversouthsiders.ca/index.php/forum

Best Answer

  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    Embed will not jump to posts automatically. It will jump to the correct page, but not the correct post. Embedding takes over the # portion of the url and takes over linking to the latest post.

    Embedding is for people that want to get a forum up in another site quickly. If your forum starts getting used more widely you really need to bite the bullet and make a theme.

Answers

  • Options
    edited December 2011

    I've done some more checking and have ruled out a couple of possible causes. It's NOT a conflict with the voting plugin, as suggested in another thread. Disabling the voting plugin has no effect on this behaviour. I've also confirmed that the AutoOffset setting is not the culprit. Changing it to false sends you to the first post in a discussion, changing it back to true sends you to where Vanilla THINKS the last post you read is.

    The unread posts plugin is working properly, so somewhere in the database it knows what the last post I read is, but it's not redirecting me there, it's sending me to a point in the thread right around when I implemented the upgrade to 2.0.18.1.

    Are there known conflicts with any other plugins? I've currently got enabled: embed vanilla, all viewed, emotify :), facebook, flagging, google sign-in, gravatar, in this discussion, last edited, open id, post count, quotes, split/merge, tiny mce, twitter, voting.

  • Options

    Further information: mobile theme works flawlessly. Users are redirected to the first unread post in a thread.

    It's only when using the embed-friendly theme that users don't get redirected.

    I'd really appreciate it if someone could help me with this. It's my last major bug.

  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    Embed will not jump to posts automatically. It will jump to the correct page, but not the correct post. Embedding takes over the # portion of the url and takes over linking to the latest post.

    Embedding is for people that want to get a forum up in another site quickly. If your forum starts getting used more widely you really need to bite the bullet and make a theme.

  • Options
    TimTim Operations Vanilla Staff
    edited December 2011

    Todd said:
    Embedding is for people that want to get a forum up in another site quickly. If your forum starts getting used more widely you really need to bite the bullet and make a theme.

    This.

    Your site's header is really not that complex so it would be easy to incorporate it into a proper theme for your forum, which would make it work so much better. You're currently getting a significantly worse (not to mention slower) version of the forum because of Embed.

    Embed was designed for places like blogs and other hosted platforms where the administrators could not easily add new pages. This is not the case for you, so there's no reason to suffer through an iframed forum.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    edited December 2011

    .

  • Options
    edited December 2011

    .

  • Options
    422422 Developer MVP

    Why the dots @chris_withers

    There was an error rendering this rich post.

  • Options

    Weird glitch. Thought I'd triple posted, so I edited two of them to periods, then the third one disappeared. Anyways, I said I'd be back, as I now get to learn about theming!

    Incidentally, the switch to Button Bar has created another issue with the Quotes plugin, which I've detailed here.

Sign In or Register to comment.