Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied. will not validate

dudieboydudieboy New
edited January 2012 in Vanilla 2.0 - 2.8

Have installed in a new folder at my site, created a custom Vanilla theme to mimic the WP theme of my site, and have activated Embed Vanilla. When I paste the URL of the forum ( into the validation box, it claims "Forum url could not be validated." I have tried all variations of the URL and none will validate.

Mind you, I'm not actually going to embed the forum into a WordPress page: the custom menu I'm using links to the actual Vanilla install, which is themed to look like my WP theme. But I would like to use the widgets, especially Recent Forum Posts.

Also having a problem with Emotify plugin as described here: Related?


  • MarkMark Vanilla Staff

    Most likely your server doesn't allow curl requests in php, which is why it's failing to validate the forum url (which it does using curl).

  • @Mark This plugin was working before when I had v.2.0.17 installed at /vanilla/, so I came up with the following test for my server:

    As you can see, it's supported.

    Since my last post I have returned

       <?php $this->RenderAsset('Head'); ?>

    to the head element of my theme's default.master.php file to fix the other plugin problem(s), but it had no effect on Embed Vanilla. The forum will still not validate in WP.

  • dudieboydudieboy New
    edited January 2012

    Have taken the following steps since the above post:

    1. Deleted plugin. Reinstalled fresh from database.

    2. Switched theme back to the default. Entered and it WORKED... for about thirty seconds. During that time I went to the Widgets admin and tried to add the Vanilla Recent Discussions widget to my sidebar. It placed, but the following error was displayed within the widget in the admin panel:

    Warning: Invalid argument supplied for foreach() in /home/danbir5/public_html/wp-content/plugins/vanilla-forums/widgets.php on line 106
    1. Viewed the site, the widget was not there. Went back to the Widget panel in the admin and it was gone from the sidebar. The Vanilla widgets have vanished from the Widget admin page as well.

    2. Tried validating the same URL again. It will not.

  • (Auto listing turned my 3 and 4 into 1 and 2, above)

  • Just contacted my host, and my hosting is set up for cURLs. Forum still will not validate with any theme, including default and EmbedFriendly. Embed Vanilla plugin is enabled and WordPress Vanilla Forums plugin is enabled. Copying and variations into the validate line repeated, but it will not work.

    Now mind you, Vanilla Forum is NOT embedded on a WP page: it's custom themed to look like it is. But this wasn't a problem with the previous version I was using, 2.0.17. Was working fine until I updated, changed my forum location. Now, :P

    Is cURL validation REALLY NECESSARY? It's never been before, on any forum software that I've ever used. Is there a way to edit the plugin so that it will accept whatever URL I give it and trust me?

    This should be a really little thing. Can anyone show me how to write a WordPress plugin that will pull the last five discussions from my Vanilla install? That's really and truly all I want.

  • Getting a little tired of posting alone here without any consideration. But, new day = new theory. Since the plugins were working together when the forum was installed in a different location ( it seems there may be something wrong with the new folder ( The permissions for all files and folders in Vanilla are set to 755, are there any changes I should make to any specific files to enable the forum URL to validate?

  • Getting a little tired of only 1 person posting in his own thread only to bump his own thread.

    That's part of the forum etiquette, dude.

    WAIT a while before you bump your own thread man. At least a couple of days.

    There was an error rendering this rich post.

  • edited February 2012

    I don't think this is a problem with cURL. I'm building a new website hosted on Hawk Host, who have cURL listed as one of their features (so like you, I assume my host allows cURL requests). I'm having the same validation issue as you, so I tried searching the internet for possible explanations. At first, when I couldn't validate, I tried fresh installs of both Wordpress and Vanilla, because there wasn't anything on the sites yet to "lose." However, when it didn't work again, I dug a little deeper, and found that the problem is likely on the Wordpress/WP plugin side of things, because [](it seems like many others are experiencing the same problem). Interestingly, the Wordpress plugin was just updated today, but the problem persists.

    Doing the "hard" embed (using the link provided on the Vanilla backend) works fine.

    I'm a beginner at this stuff, but that's how I understand the situation. If I was more knowledgeable about coding, I'd love to help work on issues like this, but right now I'm trying to learn enough to edit themes by myself. Hopefully "better men" [/batman] can help solve this problem in the future.

    Thankfully, Embed Vanilla is functional on its own. Thank you for all the hard work, Vanilla.

Sign In or Register to comment.