Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] Picked up some bugs in switch to 2.0.18 (custom theme problem)*

This discussion is related to the Quote selection addon.
dudieboydudieboy New
edited January 2012 in Vanilla 2.0 - 2.8

Hi, we've been using Quote Select a long time with no problems. But now that I've switched over to the new Vanilla, it's picked up some odd quirks:

  1. When text is selected the button says "qsQuote" instead of just "Quote" like it used to.
  2. When the button was clicked it used to send the following (example) to the #Form_Body textarea:

Jayne said:

Please consider writing a strategy guide for Microsoft and Apple about how and when to upgrade successfully.

But now it sends the following:

qsQuoteText: Please consider writing a strategy guide for Microsoft and Apple about how and when to upgrade successfully.

As you can see, it is echoing qsQuoteText instead of "Person said:" and it's appearing inside the blockquote.

How do I override these errors in the plugin's code?
(Odd how we can't use code or pre tags to format code on these forums.)

Comments

  • Hmm, okay, it appears to have something to do with my custom theme, since switching back to the default theme with 2.0.18 makes the plugin work right again. What is required in a custom theme for the plugin to work? Also, what CSS if any is required from the default theme's style.css that I may have overridden in my custom version?

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    in your custom theme do you have

    <?php
    $this->RenderAsset('Foot');
    ?>

    not having that does cause problems like that sometimes.

  • @sahotataran That did indeed fix the problem with the button and the inserting of qsQuoteText instead of the person's name. The link around the person's name still is a href="undefined" though; is it supposed to link to the quoted post?

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    edited January 2012

    m not so sure about it - may be original developer can help you with it

    did u try quotes?

  • @sahotataran That one wasn't working for me at first either, but now that I returned the foot asset to the default.master.php it's working good. Think I'll start using that one, instead; mainly because my forum users always seemed a little confused by the other.

    Thank you for your help!

Sign In or Register to comment.