Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

this problem how can i fix it?

edited March 2006 in Vanilla 1.0 Help
see this 111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111 we need fixed size....

Comments

  • Options
    edited March 2006
    I believe we can fix this by setting in the stylesheet on the CommentBody class overflow: Scroll.

    I think there is another style that may have to be set to get it working properly...Let me test!

    Edit:
    Add a new line in global.css around line 560 or so:
    overflow: auto;
    Overflow: scroll will add scrollbars to all posts, auto will use them only when needed.
  • Options
    As far as I know, overflow:auto doesn't work in IE
  • Options
    edited March 2006
    Isn't this word wrapping?
    For example:

    <div STYLE="word-wrap: break-word">blablablablablabla</div>
  • Options
    edited March 2006
    wrong post sry
  • Options
    It isn't word-wrapping, because the string in question has no spaces. It is treated as one word as far as layout goes.

    It is certainly possible to turn character wrapping on and fix that problem, but I doubt that would be acceptable.

    The two main situations in my forum that cause the scroll are big pictures, and long URLs
  • Options
    edited March 2006
    Tested with I.E. 6.0--It turns out you have to specify the width, which forces IE to restrict the box and give the scrollbars a fighting chance.

    So you have to add two lines under .CommentBody:
    overflow: auto; width: 99%;

    Here is a demo for others to try:
    http://edacio.us/forum/comments.php?DiscussionID=23

    Edit:
    MS says that it should work for I.E. 4.0 and later.
  • Options
    I seem to remember overflow: scroll working just fine on lechs root styles. And i'm pretty sure scroll bars only popped up when they were needed. I might be going insane though.
  • Options
    Thanx guys, am still working on it!!!!
  • Options
    i need another way.... this way is not good >... ):
  • Options
    Well... the only way to break it without the scrollbar would be to insert a breaking character (such as a space) at intervals in the string, whenever the string runs on without one. (Google does this with the green text below their search results, if you try it in I.E.) Splitting is not recommended if the text is copy/paste code or URLs. But clickable URL text could be split in this manner. If you want to limit the width of images, they will have to have width coded in the CSS, which could get ugly. Or use a thumbnailer to show a thumbnailed version with a link to the large image.
  • Options
    The scroll thing seems to be acceptable--do you see any problem with that?
  • Options
    lechlech Chicagoland
    if it's for a clickable url, I would recommend that the function which handles auto-linking possibly be patched (if it already isn't) to shorten the display url after 50+ characters.
This discussion has been closed.