Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Markdown posts are not displaying?

edited March 2006 in Vanilla 1.0 Help
Hello, I've got Vanilla installed fine, and it was all working swell as far as I could tell, until the past day. Now, all posts that have Markdown enabled on them are invisible, though if you go to "Edit" your post, the content is still there. Also, at the top of any discussions that have at least one post with Markdown enabled in it, there is the following warning: Warning: preg_replace_callback() [function.preg-replace-callback]: Unknown modifier '|' in /home/.tadey/morgon/rosecreekvillage.com/talk/extensions/Markdown.php on line 810 Warning: preg_replace_callback() [function.preg-replace-callback]: Unknown modifier '|' in /home/.tadey/morgon/rosecreekvillage.com/talk/extensions/Markdown.php on line 810

Comments

  • Options
    MarkMark Vanilla Staff
    Has anything changed on your server?

    Vanilla doesn't randomly change the way it works, so if it worked before and it doesn't work now and you didn't alter Vanilla in any way, then it is a server issue.

    One thing you can do right away to solve the problem is disable the markdown extension. When you do, all of those markdown posts will revert to basic text and display properly. If you later manage to figure out what is wrong with the markdown code and you re-enable the markdown extension, those posts will pick up that markdown is reactivated and work properly.
  • Options
    Mark, I'm hosted with Dreamhost, and as far as I know, nothing's changed. I'm going to go ahead an disable Markdown, though. Thanks for the suggestion.
  • Options
    Now you come to mention it though, random changes in how stuff works could be pretty fun. Muchos confusing though. Might even be worth just reinstalling the extension for the sake of trying.
  • Options
    Dreamhost upgraded php which changes the syntax of preg_replace_callback() You can easily fix the problem by upgrading to the latest version of Markdown (http://www.michelf.com/projects/php-markdown/) Just open up extensions/Markdown.php and replace the Markdown specific code (everything after line 45) with the new stuff.
This discussion has been closed.