HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

After uploading vanilla to wordpress portion of site, now the forums portion does not work

edited January 2012 in Vanilla 2.0 - 2.8

My vanilla forums are not working.

I had functional, working forums here: http://nolamil.com/forums.

Here I have wordpress driven section of my site: http://nolamil.com/info

After installing the vanilla plugin on my wordpress portion, my forums are broken. I just get the "bonk" page.

Thanks for any help out there! Oh, I did try removing the plugin but it's still broken. I completely deleted from my server so I just don't konw what to do

Best Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Accepted Answer

    OK Tammie, I think that in your cache folder you need to create a folder called Smarty (use capital S) and inside that a folder called compile (all lower case).

    That sorted me out when I had that (or a very similar) error.

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Accepted Answer

    @TammieEarl its when you clear all the cache folder at once - you delete .ini files and Smarty folder - which is used by the Smarty engine - and is used if you use a .tpl file as a template to your forums. So you will have to watch this folder - next time you clear the cache folder :)

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    edited January 2012 Accepted Answer

    compile is just the folder - you might have to create a folder named compile inside smarty folder to make it work

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited January 2012 Accepted Answer

    Yes, 'compile' is the folder name.

    cache/Smarty/compile

Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited January 2012

    Tammie - first thing is to get past the 'Bonk' message.

    You need to access the Vanilla/conf folder on your webserver, and

    if you are using vanilla >= 2.0.18 Put

    $Configuration['Garden']['Debug'] = TRUE; `
    

    and if its < 2.0.18 put

    `$Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';`
    

    in your config.php file.

    This will give you a detailed error message, rather than the 'Bonk' one. Once you have that, either it will help you see what to do, or else you can post another question, asking specifically about the error.

    tbh even though I'm on 2.0.18 I found the 2nd option worked for me.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    You might also try deleting the .ini files (not the folders) in the cache folder.

  • It's getting hung up on the addition to the conf file:

    Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home8/vonwardk/public_html/nolamil/forums/conf/config.php on line 38

  • edited January 2012

    Figured out what I did wrong with the code you gave me. I finally got it right and below is the copied and pasted information I got INSTEAD of the bonk message

  • Fatal Error in Smarty.trigger_error();

    Smarty error: the $compile_dir '/home8/vonwardk/public_html/nolamil/forums/cache/Smarty/compile' does not exist, or is not a directory.

    The error occurred on or near: /home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php

    1109: * @param integer $error_type 1110: */ 1111: function trigger_error($error_msg, $error_type = E_USER_WARNING) 1112: { 1113: trigger_error("Smarty error: $error_msg", $error_type); 1114: } 1115: 1116: 1117: /**
    Backtrace:

    [/home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php:1113] PHP::Gdn_ErrorHandler(); [/home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/internals/core.write_compiled_resource.php:20] Smarty->trigger_error(); [/home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php:1451] PHP::smarty_core_write_compiled_resource(); [/home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php:1274] Smarty->_compile_resource(); [/home8/vonwardk/public_html/nolamil/forums/library/vendors/Smarty-2.6.25/libs/Smarty.class.php:1126] Smarty->fetch(); [/home8/vonwardk/public_html/nolamil/forums/library/core/class.smarty.php:81] Smarty->display(); [/home8/vonwardk/public_html/nolamil/forums/library/core/class.controller.php:1566] Gdn_Smarty->Render(); [/home8/vonwardk/public_html/nolamil/forums/library/core/class.controller.php:1141] Gdn_Controller->RenderMaster(); [/home8/vonwardk/public_html/nolamil/forums/library/core/class.pluggable.php:193] Gdn_Controller->xRender(); [/home8/vonwardk/public_html/nolamil/forums/applications/vanilla/controllers/class.categoriescontroller.php:196] Gdn_Pluggable->__call(); [/home8/vonwardk/public_html/nolamil/forums/applications/vanilla/controllers/class.categoriescontroller.php:196] CategoriesController->Render(); [/home8/vonwardk/public_html/nolamil/forums/library/core/class.dispatcher.php:322] CategoriesController->All(); [/home8/vonwardk/public_html/nolamil/forums/index.php:53] Gdn_Dispatcher->Dispatch();
    Variables in local scope:

    [error_msg] 'the $compile_dir \'/home8/vonwardk/public_html/nolamil/forums/cache/Smarty/compile\' does not exist, or is not a directory.' [error_type] 256
    Need Help?

    If you are a user of this website, you can report this message to a website administrator.

    If you are an administrator of this website, you can get help at the Vanilla Community Forums.

    Additional information for support personnel:
    •Application: Vanilla
    •Application Version: 2.0.18.2
    •PHP Version: 5.2.17
    •Operating System: Linux
    •Server Software: Apache
    •User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)
    •Request Uri: /forums/
    •Controller: Smarty
    •Method: trigger_error

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Accepted Answer

    OK Tammie, I think that in your cache folder you need to create a folder called Smarty (use capital S) and inside that a folder called compile (all lower case).

    That sorted me out when I had that (or a very similar) error.

  • Hmm. Well a similar thing happened only a week or so ago. Having the same issues but they don't present themselves the same... and having to re-do the fixes. Thank you whu606, you've been very helpful. I will come back and accept your answer once I have time to try this fix.

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Accepted Answer

    @TammieEarl its when you clear all the cache folder at once - you delete .ini files and Smarty folder - which is used by the Smarty engine - and is used if you use a .tpl file as a template to your forums. So you will have to watch this folder - next time you clear the cache folder :)

  • OK, made the Smarty folder again. So compile - does it have an ending? LIke is it compile.tpl or compile.ini? Thanks for the help guys, I hope we are almost there!

  • I'm just getting a white screen now. Not the bonk, not the long message... is this good? What next? Here's the site: http://nolamil.com Here's the troubled link: http://nolamil.com/forums Thanks so much guys! I REALLY appreciate the help!

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    edited January 2012 Accepted Answer

    compile is just the folder - you might have to create a folder named compile inside smarty folder to make it work

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited January 2012 Accepted Answer

    Yes, 'compile' is the folder name.

    cache/Smarty/compile

Sign In or Register to comment.