Please upgrade here. These earlier versions are no longer being updated and have security issues.

How to enable curl on Windows 2003?

edited January 2012 in Vanilla 2.0 - 2.8

I have installed Vanilla on a Windows 2003 server. In the php.ini I have the following entry:

extension=php_curl.dll

I guess that means that as far as PHP is concerned, curl is enabled. I'm not sure if there is a way to verify this. In Vanilla, plugins like Facebook authentication cannot be enabled saying "This plugin requires curl.". Google Sign In can be enabled, but when I attempt to use it I get a "Bonk".

I've downloaded the latest version of curl for Windows, but it is just an exe file. What am I supposed to do with it? Any suggestions on how enable curl?

Best Answer

  • JongosJongos
    Accepted Answer

    no problem...

    you have to restart apache everytime you make change to php.ini.

    restart apache == reload php

Answers

  • JongosJongos
    edited January 2012

    in your web root, create a file called phpinfo.php

    in that file paste this :

    <?php phpinfo(); ?>

    now go to your browser and direct it to that file

    for example : http://localhost/phpinfo.php

    see if curl mentioned anywhere in the page.

    You can also check the php.ini file used by your php.

    sometime a stack could have many php.ini but only one is used by the system.

  • Thanks. I did that already and curl is not mentioned anywhere. The script confirms that the right php.ini is used (the one that has that curl extension enabled).

  • On wallpaperama.com/forums/how-to-find-out-if-php-is-compiled-with-curl-extension-installed-enabled-t1576.html I found a script that can be used to verify if curl is enabled and it appears that it is. Yet, the Vanilla plugins don't agree with it.

  • Well, it turns out that you need to restart the Apache server to get it to realize that curl is enabled. I did that and now the Facebook plugin doesn't complain anymore. Thanks, Jongos for your time.

  • JongosJongos
    Accepted Answer

    no problem...

    you have to restart apache everytime you make change to php.ini.

    restart apache == reload php

Sign In or Register to comment.