Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied. Import fails silently - No idea where to go from here

edited January 2012 in Vanilla 2.0 - 2.8

Trying to upgrade to but the import just fails silently. Been using the latest vanilla2exporter.php to export my 2.0.6 database, but when importing the file through the admin menu nothing happens:

  • If using a zipped .txt.gz file (as generated by the exporter), the import page keeps the email and password information but presents the error "ImportFile is required".
  • If using an unzipped .txt file, the import page forgets all previous input and presents three errors; "You must select a file to import.", "Email is required." and "Password is required."

My current installation is a fresh with no changes what so ever. I've tried all different combinations of "Use my Current Password" and "Generate import SQL only", but I never got past the import input page.

As I'm unable to see any sort of error message, I have no idea where to go from here. Please advice! I even tried adding;

$Configuration['Garden']['Errors']['LogEnabled'] = TRUE;
$Configuration['Garden']['Errors']['LogFile'] = 'logs/error-log';
$Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

but no logs/ directory is created, so I'm assuming no errors there. (I've restarted apache).

Also tried clearing the cache directory and verified directory permissions to uploads/conf/cache directories.



  • edited January 2012

    @setomidor You should try to use a free software loading service. This way all updates are one click simple. Too many issues to followup if the platform does not support auto-updating similar to WordPress.

    You may need to do a new install first, but once the system is established the updates are very, very simple to do.

    Hope this helps today and for the future. has over 250 different programs to use and install free.


  • Hrm, actually, can't really see how this helps at all. Even if I would make a new install I would of course have to import all the previous data from my 2.0.6 production forum, and that update would fail just as it does now.

  • why are you even doing it this way?

    did you follow

    back up your db before.

    grep is your friend.

  • most likely reason for failure using the porter, are the mysql privileges and format/corruption

    grep is your friend.

  • I have the same problem although 5 times tried, and another problem with is it not save my cookie, I logged in, move to another page and I haved logged out :(

Sign In or Register to comment.