Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Embedding to WordPress, can't see Remote Url options in Vanilla

edited February 2012 in Vanilla 2.0 - 2.8

Hi! I'm trying to embed Vanilla Forums to WordPress, but I can't see Remote Url options in .../vanilla/plugin/embed. I can only see:

  • Forum Code
  • Forum Embed Plugins
  • Current Theme
  • Theme Options

But not Remote Url settings, which should be under there, right?

How to solve this problem?

Thank you!

Best Answer

  • x00x00 MVP
    edited February 2012 Answer ✓


     $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = "";

    in your config/config.php file.

    grep is your friend.


  • They should be under there. They are on my install, at least, even though I'm still having trouble configuring the plugin on the Wordpress end (won't validate with WP3.3.1, and the latest update hasn't helped either, unfortunately).

    Do you have the latest version of the plugin and Vanilla? When I installed Vanilla via my web host, it was pre-loaded, but perhaps you should try re-installing the plugin?

    Sorry for my simpleton answer, but I'm not a coding pro or anything.

  • Thank you for the reply! There is just one version of the plugin and it is made in october 2010. Is there newer version somewhere else?

    I re-installed the plugin, but it didn't help. I'm using latest versions of Vanilla Forums and WordPress. I validate my forum in WordPress and there was no problem.

  • You're using WP 3.3.1 and able to validate? I guess I'm getting stuck on a different step. Sorry that I can't be of more help.

  • Yes I have WP 3.3.1 and at least it says "validated :)" or something like that. Thank you for your help anyway. I hope you get your problems solved.

  • edited February 2012

    I did a search (I think it was on Google, but it may have pointed me back to these forums) and it looks like you're not the first person that experienced this. Try a quick search and maybe an answer will turn up in that thread.

    But it was a few hours ago, and I can't search for it again now - wife calls!

  • I figured out what might have caused your problem, but I don't have any clue how to fix it. I deleted the remote URL, hit save, and when it reloaded the page, the whole bottom section was gone. Like I said, no idea how to get it back, but deleting that URL probably messes up the code or something.

  • Yeh, I found discussions where others were asking the same thing, but I didn't found any solutions yet.

    I deleted the database and made new one and I reinstalled the Vanilla Forums, but the problem is still there. That's very strange.

    My community is still using phpBB, but I would like to change to Vanilla Forums and Wordpress. So I have done all testing with test forum.

    On last summer I tried Vanilla Forum first time and I installed it, but I decided to wait until Vanilla becomes even better, so I uninstalled it. There was some problems while uninstalling. On my server, theres still Vanilla_2.0.17.10-folder and it includes:

    uploads/LocaleDeveloper- captured.php

    • captured_admin.php
    • definitions.php
    • changes.php
    • copied.php

    Maybe this old install folder causes my problems. I have no idea how to delete it. When I try to delete it, it says:

    Permission denied

  • That's unbelievable!

    I had to "Reset owner" in file manager before I could delete those folders and files. Once again I reinstalled Vanilla Forum, but the problem is still there. I can't see Remote Url options.

  • that part of the code has

    if (C('Plugins.EmbedVanilla.RemoteUrl')) {

    So if $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] is set to false or not there it will not render that part of the form.

    grep is your friend.

  • Thank you for reply!

    So where exactly that code should be? I tried to search for it, but I didn't find it.

  • x00x00 MVP
    edited February 2012 Answer ✓


     $Configuration['Plugins']['EmbedVanilla']['RemoteUrl'] = "";

    in your config/config.php file.

    grep is your friend.

  • Thank you very much for help! It worked!

    Now I can see Remote Url option, but I can't see "Dashboard Embed" (check image in first post). I think I should add another line of code to config.php?

    I didn't succeed to embed my forum yet. I added the embed code to new page, but I can see just default page with blank content box.

  • I think the problem is you are using the plugin from the addon section rather than the one shipped with vanilla.

    this is just my snooping, I have nothing to do with these plugins.

    grep is your friend.

  • I was using the one which came with Vanilla. In fact I tried both.

    I changes some settings and now everything is working nicely and forum is embedded :) Thank!

Sign In or Register to comment.