Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

max_user_connections Errors - Please help!

edited February 2012 in Vanilla 2.0 - 2.8

Hi everybody,

Right off the bat I should admit that I'm out of my depth here. My vanilla forum became very popular very fast, and now I'm getting "bonk" errors every few days. When I investigate the Bonks I get a max_user_connections error.

My temporary fix for this is to just add a new user to the database and update the config.php file accordingly. That works, but after a few days the Bonk error comes back.

My host says that the problem might be that my Wordpress installation on the same server is taking up too many resources. I've installed a WP caching plugin to (hopefully) deal with this, but is there anything else I can do to stop the Bonks?


  • Options

    Just wondering what is your URL?

  • Options

    I get a max_user_connections error.

    Isn't a max_user_connections error a standard MySQL problem with (hopefully) many google search results?

    There was an error rendering this rich post.

  • Options

    this couuld be down to a number of things: One thing to try is PDO::ATTR_PERSISTENT => FALSE set in config

                                                      12 => TRUE, //PDO::ATTR_PERSISTENT => TRUE,
                                                      1000 => TRUE, // PDO::MYSQL_ATTR_USE_BUFFERED_QUERY is missing in some php installations
                                                      1002 => "set names 'utf8'" // PDO::MYSQL_ATTR_INIT_COMMAND is missing in PHP 5.3, so I use the actual value "1002" instead

    grep is your friend.

Sign In or Register to comment.