Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

iOS Scrolling Bug?

edited March 2012 in Vanilla 2.0 - 2.2

When viewing the forum on Safari in iOS, a weird bug manifests in some discussions where as soon as you release your thumb after scrolling up or down, the page jumps back down to where it originally loaded.

Known Workarounds

  • Refreshing the page.

  • Quoting the visible post.

Both of these options allow the user to scroll freely.

Troubleshooting Steps Taken

  • Installing a fresh copy of Vanilla with no add-ons, plugins or themes, pointed at the same database, to confirm that the bug does not manifest on vanilla Vanilla.

  • Disabling all plugins.

  • Installing alternate mobile themes.

  • Copying the content of /uploads, /plugins and /themes to the basic forum to determine exactly when the bug begins to manifest.

Possible Causes Ruled Out

  • The bug does not appear to be triggered by any of the currently installed plugins.

  • The bug does not appear to be triggered by the mobile theme, as installing a different theme has no effect.

  • The bug does not appear to be triggered by an error in the database, as a discussion that causes problems for a user at one time will not necessarily cause problems for a different user at the same time.

Current Theory

  • I believe I may be able to trigger the bug by copying the /uploads folder from the live forum to my test forum.

I apologize for making a duplicate thread, but the other one was very scattered and I wasn't getting any assistance there, so I thought I'd try again with a more focused thread. Can anyone out there assist me?

Live forum: http://www.vancouversouthsiders.ca/forum

Basic forum: http://www.vancouversouthsiders.ca/basicforum

Comments

  • I don't know if this is related, but it may provide some insights.
    http://forum.jquery.com/topic/scrolling-problem-in-chrome-safari.

    seems there are a few posts if you google "scrolling safari jquery"

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Interesting. I've tried creating a new mobile theme with a custom.css where all instances of overflow:hidden are changed to visible, just to see what happens. No change, the bug still presents. There was another post that said to add position:relative if you want to use overflow:hidden with mobile Safari. No dice there, either.

  • After having several users test the basic forum on their iPhones, I've confirmed that they weren't having any issues on a plain install of Vanilla.

    I then copied the userpics folder from my existing forum into the basic forum and started getting the bug.

  • 422422 Developer MVP
    edited March 2012

    Is that with default css or now again with custom.css

    Have you considered testing with http://www.iwebinspector.com/

    422 Real Estate Australia , now open Check it out

  • I've tested with both. Both still have the bug.

  • edited March 2012

    422 said:
    Have you considered testing with http://www.iwebinspector.com/

    Ok, possible issue found. I replicated the bug here: http://vancouversouthsiders.ca/forum/discussion/1574/predictions-for-whitecaps-2012#Item_104

    At the time of the bug there were only three comments displaying on the page.

    <li class="Item Comment Alt" id="Comment_68732">
    <div class="Comment">
    <div class="Meta">
    <span class="Author">
    <a title="slamo" href="/forum/profile/67/slamo" class="ProfileLink"><img src="http://vancouversouthsiders.ca/forum/uploads/userpics/n33ZZJQ6JBCFA.jpg" alt="slamo" class="ProfilePhotoMedium" /></a><a href="/forum/profile/67/slamo">slamo</a> </span>
    <span class="DateCreated">
    <a href="/forum/discussion/comment/68732#Comment_68732" class="Permalink" name="Item_102" rel="nofollow">9:20AM</a> </span>
    <span class="CommentQuote"><a href="http://vancouversouthsiders.ca/forum/post/quote/1574/Comment_68732">Quote</a></span><span><a href="/forum/vanilla/post/editcomment/68732" class="EditComment">Edit</a></span><span><a href="/forum/vanilla/discussion/deletecomment/68732/L3MUVM3R8ZE0?Target=%2Fdiscussion%2F1574%2Fx" class="DeleteComment">Delete</a></span><div class="Options"><span class="AdminCheck"><input type="checkbox" name="CommentID[]" value="68732" /></span></div> <div class="CommentInfo">
    <span>Posts: 1,170</span> </div>
    </div>
    <div class="Message">
    <p>The three game road trip that brings 7 points in July against Chivas, TFC and Chicago will cure any ails that occur throughout May/June.</p>
    </div>
    </div>
    </li>
    <li class="Item Comment" id="Comment_68734">
    <div class="Comment">
    <div class="Meta">
    <span class="Author">
    <a title="Lord_Bob" href="/forum/profile/52/Lord_Bob" class="ProfileLink"><img src="http://www.gravatar.com/avatar.php?gravatar_id=b4a650f0891fecff1c169053499f644d&amp;size=50&amp;default=http%3A%2F%2Fvancouversouthsiders.ca%2Fforum%2Fplugins%2FGravatar%2Fdefault.gif" alt="Lord_Bob" class="ProfilePhotoMedium" /></a><a href="/forum/profile/52/Lord_Bob">Lord_Bob</a> </span>
    <span class="DateCreated">
    <a href="/forum/discussion/comment/68734#Comment_68734" class="Permalink" name="Item_103" rel="nofollow">9:30AM</a> </span>
    <span class="CommentQuote"><a href="http://vancouversouthsiders.ca/forum/post/quote/1574/Comment_68734">Quote</a></span><span><a href="/forum/vanilla/post/editcomment/68734" class="EditComment">Edit</a></span><span><a href="/forum/vanilla/discussion/deletecomment/68734/L3MUVM3R8ZE0?Target=%2Fdiscussion%2F1574%2Fx" class="DeleteComment">Delete</a></span><div class="Options"><span class="AdminCheck"><input type="checkbox" name="CommentID[]" value="68734" /></span></div> <div class="CommentInfo">
    <span>Posts: 1,812</span> </div>
    </div>
    <div class="Message">
    <blockquote>
    <p>krisaug5 said:</p>
    <blockquote>
    <p>Lord_Bob said:</p>
    <blockquote>
    <p>slamo said:When we start 3-0-0; confidence won't be an issue. Montreal, Chivas and then a DCU team that will be in gel mode.</p>
    </blockquote>
    <p>Last year our first three games were a dominant win to Toronto, a draw against Sporting Kansas City that was even more incredible than the win, and a highly credible loss away. I agree that all three of those teams are, on paper, there for the taking, but teams at Vancouver's level don't tend to run off 3-0-0 starts against <em>anybody</em> and even if we do, it takes more than three games to set the tone for a season.</p>
    </blockquote>
    <p>Loss to Philly.... The Hassli-card issues and a relatively late goal from le Toux I believe</p>
    </blockquote>
    <p>I should learn not to trust my memory.</p>
    </div>
    </div>
    </li>
    <li class="Item Comment Alt" id="Comment_68925">
    <div class="Comment">
    <div class="Meta">
    <span class="Author">
    <a title="DutchCrunch" href="/forum/profile/3017/DutchCrunch" class="ProfileLink"><img src="http://www.gravatar.com/avatar.php?gravatar_id=272fbd52621fe4d88c2be87f4a5cc987&amp;size=50&amp;default=http%3A%2F%2Fvancouversouthsiders.ca%2Fforum%2Fplugins%2FGravatar%2Fdefault.gif" alt="DutchCrunch" class="ProfilePhotoMedium" /></a><a href="/forum/profile/3017/DutchCrunch">DutchCrunch</a> </span>
    <span class="DateCreated">
    <a href="/forum/discussion/comment/68925#Comment_68925" class="Permalink" name="Item_104" rel="nofollow">5:39PM</a> </span>
    <span class="CommentQuote"><a href="http://vancouversouthsiders.ca/forum/post/quote/1574/Comment_68925">Quote</a></span><span><a href="/forum/vanilla/post/editcomment/68925" class="EditComment">Edit</a></span><span><a href="/forum/vanilla/discussion/deletecomment/68925/L3MUVM3R8ZE0?Target=%2Fdiscussion%2F1574%2Fx" class="DeleteComment">Delete</a></span><div class="Options"><span class="AdminCheck"><input type="checkbox" name="CommentID[]" value="68925" /></span></div> <div class="CommentInfo">
    <span>Posts: 7</span> </div>
    </div>
    <div class="Message">
    <p>Yeah, Hassli got his first red, but FWIW it was Carlos Ruiz who scored for Philly...</p>
    </div>
    </div>
    </li>
    </ul>

    The first poster's avatar (slamo) has been uploaded to the forum, and is being linked to and displayed correctly. The third poster has not uploaded a picture to the forum, and so the Gravatar plugin is kicking in and showing a default Gravatar for him. The second poster (lord_bob) has not uploaded a picture to the forum, but the website is rendering a picture even though the profilelink is pointing to the default Gravatar.

    I went in and checked GDN_User, and photo is NULL for lord_bob. It's nevertheless showing a photo that he's been using for months.

  • Never mind. Obviously, this is because he actually has a Gravatar.

  • Any news for that? We have the same issue on our new vanilla forum (even when there where 3 only 3 users which all had a working gravatar-account) and had to remove the item-anchor for the mobile theme...

  • I'd given up trying to figure this out, as it's incredibly frustrating. I've never been able to accurately figure out when it happens. It's either an incredibly rare bug, or people don't use mobile themes with vanilla forums very often.

  • peregrineperegrine MVP
    edited April 2012

    is the problem occurring only for gravatars? or user photos as well?

    if so, have them grab the avatar image and upload it as a photo, and see if that solves it.
    save as image
    http://www.gravatar.com/avatar.php?gravatar_id=272fbd52621fe4d88c2be87f4a5cc987

    and upload in a profile as a photo.

    it that works - you could convert all users in the user table.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • It happens much more frequently when all posted comments are from people with uploaded user pics. I've seen it happen with all gravatars too.

  • I'm having this issue as well. Only occurs on Safari on my iPhone, not on Chrome.

  • Having this also, any fix? :(

Sign In or Register to comment.