Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My forum goes Bonk when applying themes

edited March 2012 in Vanilla 2.0 - 2.8

Hi there everybody, thanks for taking the time to look at my issue.

What's happening for me is that every time I try and apply any theme other than the default one, my forum goes Bonk. I have tried disabling every plugin, but that does nothing. I saw it written somewhere that there was a cache/smarty folder, but that folder doesn't exist, and that's basically what it said when I added the debug code to my configuration file.

I installed Vanilla Forums using Simplescripts, if that makes a difference.

Best Answer

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Answer ✓

    If the folder Smarty (note capital letter) is not in your cache folder then you need to create it.

    Then, within Smarty create a folder called compile (no capital letter).

    That should resolve the error.

    starpause

Answers

  • Oh yes, and when I add

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; to my configuration file I get the following error: pastie.org/3574982

  • UnderDogUnderDog MVP
    edited March 2012

    Welll... you're very good in using pastie, that's for sure...

    Focus on this error:

    Smarty error: the $compile_dir '/path/to/public_html/cache/Smarty/compile' does not exist, or is not a directory

    It is probably a permission issue for the /cache directory on /public_html

    By the way:
    When you wrote you changed that little line in the config file, I can conclude that you're not using the latest version of Vanilla. When your problem is resolved I would upgrade to the latest version (backup, backup, backup)

    There was an error rendering this rich post.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    Answer ✓

    If the folder Smarty (note capital letter) is not in your cache folder then you need to create it.

    Then, within Smarty create a folder called compile (no capital letter).

    That should resolve the error.

    starpause
  • Smarty should create that directory, in my opinion, but you should have the proper permissions to do so.

    I've used many CMS systems with Smarty in the past and you never had to create directories for Smarty, Smarty was ... smart enough (pun intended) to create those directories

    There was an error rendering this rich post.

  • x00x00 MVP
    edited March 2012

    it is not smart enough to create them when deleted.

    grep is your friend.

  • Thank you whu606, that solution actually worked! The forum is now not throwing errors every time you try and visit any page, and I can apply any themes that I wish.

    However UnderDog, that conclusion of yours that I'm not using the latest version of vanilla forums is interesting. Simplescripts says that I'm running Vanilla Forums version 2.0.18.3.

    Also, It's odd how Smarty didn't create the folders itself. The folder permissions for the cache folder are 755.

  • 422422 Developer MVP

    Are you on apache?

    There was an error rendering this rich post.

  • RegretZero said:
    However UnderDog, that conclusion of yours that I'm not using the latest version of vanilla forums is interesting. Simplescripts says that I'm running Vanilla Forums version 2.0.18.3.

    In that case, maybe I'm mistaking. Since 2.0.18.2 you need to change a debug setting to "true", but maybe the old way also still works. If you have the right version, then ignore my paragraph :-)

    There was an error rendering this rich post.

  • whu606 said:
    If the folder Smarty (note capital letter) is not in your cache folder then you need to create it.

    Then, within Smarty create a folder called compile (no capital letter).

    That should resolve the error.

    Ok--I must be missing something. I have the same issue and can see the Smarty folder->config folder->empty. I have deleted them both and re-created with the same result--the folder is empty.

    Question: is there some sort of code I'm supposed to know to put in the config folder so it won't be empty? Please help, as I have reached my point of giving up and using boring phpBB to install my forum. Thanks in advance for any and all help.

  • mspiva1 said:

    whu606 said:
    If the folder Smarty (note capital letter) is not in your cache folder then you need to create it.

    Then, within Smarty create a folder called compile (no capital letter).

    That should resolve the error.

    Ok--I must be missing something. I have the same issue and can see the Smarty folder->config folder->empty. I have deleted them both and re-created with the same result--the folder is empty.

    dleleted which both?

    give all the permissions on your Smarty directoriy and Smarty subdirectory names and permissions
    paste the results of your debug info.

    Question: is there some sort of code I'm supposed to know to put in the config folder so it won't be empty? Please help, as I have reached my point of giving up and using boring phpBB to install my forum. Thanks in advance for any and all help.

    usually you get no answers when you provide no specific information with respect to YOUR problem.
    me too, same thing doesn't cut it. If you do really want some vanilla help.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Thanks Peregrine for the reply. I was able to get assistance from another person, who explained how to post in this forum (I'm new and they were patient and kind in teaching me how to provide additional information to get the help I needed.)

    The result of my problem was that I was following the instructions on the threads to a tee, just in the wrong Smarty folder. I was in the Themes folder and not the correct path of forum-->cache and then create a Smarty-->compile folder there.

    I do notice that the range of know how is vast here and maybe knowing the correct path is a given for most but not for me as I have never seen this type of stuff before. Again, thanks for not making me, a neophite in understanding under the hood stuff, feel stupid or less than you all with more experience and know how feel badly.

    I will continue to persevere and eventually stop getting Bonk errors whenever I add something to my new forum.

    422
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited June 2012

    @mspival - most users on here will go the extra comment to help.

    The full path is given in the error message, once you get past the Bonk screen, and was also referenced in a response to the original question, which is why people probably didn't reference it again.

  • Thanks whu606--I will admit--that error message screen sent me in to overload shock and just looked like greek to me. You all have been so kind. Now, I have to find the thread to learn how to stop getting a bonk when my users try to sign up and get a confirm email...

    So, I'm off to the files on here...wish me luck!

  • 422422 Developer MVP

    Good luck.

    There was an error rendering this rich post.

  • mspiva1 said:
    Now, I have to find the thread to learn how to stop getting a bonk when my users try to sign up and get a confirm email...

    @mspiva1 You have to turn on the error page again, so you can see the 'greek' information for us 'geeks' to interpret.

    If you've found the thread(s) about your problem, PM me the titles (Urls) of those threads, I'll try to help. But we need those 'greek' details :-)

    There was an error rendering this rich post.

Sign In or Register to comment.