Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved][Documentation] Problem with parsing HTML

castaldicastaldi New
edited April 2012 in Vanilla 2.0 - 2.8

Hi all,

I've installed a clean version of the newest Vanilla forum and imported some data from SimplePress. Everything works fine, except for the parsing.

All HTML-code is shown in the posts and not is being parsed. This happens to all excisting posts, but to new posts as well. There are no linebreaks and also the smile-plugin (Emotify) doesn't work.

Does anyone have any idea how to solve this?

Thanks a lot in advance!

Comments

  • UnderDogUnderDog Moderator

    Look in the database through PHPMyAdmin and look at exactly 1 record that was imported from SimplePress

    Look at the field 'Format' it should read 'Html'

    Open conf/config.php

    Look at the value of the configuration for InputFormatter

    Mine is set to 'Markdown', because I'm using the ButtonBar plugin

    $Configuration['Garden']['InputFormatter'] = 'Markdown';
  • Thank you for your reply!

    The Format field reads HTML so that must be fine.

    The inputFormatter wasn't set in my config.php. I've added your line but that doesn't solve the problem. Also, the line under tthe comment field (saying "You can use Simple Html in your post." is not changed than.

    The only lines that are in my config.php that can effect HTML are:

    $Configuration['Garden']['Html']['SafeStyles'] = FALSE;

    and

    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';

  • I solved the problem myself. I found out that there was no plugin installed called 'htmllawed'. I downloaded the plugin from GitHub, installed it and it works now.

  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    edited December 2012

    The problem is mainly, that the "HtmLawed" Plugin is set to "visible=FALSE" - so you can't find it via Dashboard > Plugins. Just paste the following line to your config.php in order to enable HTML-Parsing:

    $Configuration['EnabledPlugins']['HtmLawed'] = TRUE;

  • @oliverraduner

    Is it supposed to be:

    $Configuration['EnabledPlugins']['HtmLawed'] = TRUE;

    or

    $Configuration['EnabledPlugins']['HtmLawed'] = 'Htmlawed';

    Or will either work?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    $Configuration['EnabledPlugins']['HtmLawed'] = TRUE;

  • It makes no difference as it is and interactive pluign so is always enabled.

    grep is your friend.

Sign In or Register to comment.