Please upgrade here. These earlier versions are no longer being updated and have security issues.

Statistics dashboard displaying re-framed inside itself

LeeHLeeH
edited March 2012 in Vanilla 2.0 - 2.8

Preface: I'm running a github clone of Vanilla 2.1a, so if this is the cause of my problem, then I totally understand and I'll shut up about it :)

Enabling the Vanilla Statistics plugin causes the dashboard front page to be displayed again inside of itself—looks like this. I can duplicate the behavior in Firefox, Safari, and Chrome. Is this just a 2.1 incompatibility that will eventually be fixed, or am I doing something wrong?

Comments

  • Anyone else at all experiencing this? Would love to know if there's a fix. I've been unable to figure it out.

  • Will bump for help one final time, and then let it go.

  • I'm experiencing this with Vanilla Version 2.0.18.4.

    It's something to do with a rewrite rule, because when I set $Configuration['Garden']['RewriteUrls'] to FALSE in the config.php file it goes back to working normally.

    Attached is a screenshot.

    Here's my Nginx config:

    server {
        server_name www.site.ca site.ca;
        access_log /home/user/www/site.ca/logs/access.log;
        error_log /home/user/www/site.ca/logs/error.log;
    
        root /home/user/www/site.ca/public;
    
        location / {
            index index.html index.php;
        }
    
        # Enforce no www
        if ($host ~* ^www\.(.*))
        {
            set $host_without_www $1;
            rewrite ^/(.*)$ $scheme://$host_without_www/$1 permanent;
        }
    
        # Removes Trailing Slashes
        if (!-d $request_filename)
        {
            rewrite ^/(.+)/$ /$1 permanent;
        }
    
        # Unless the request is for a valid file (image, js, css, etc.), send to bootstrap.
        if (!-e $request_filename)
        {
            rewrite ^/(.*)$ /index.php?/$1 last;
            break;
        }
    
        # Catch All
        error_page 404 /index.php;
    
        location ~ \.php$ {
            try_files $uri =404;
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass unix:/tmp/php5-fpm.sock;
            fastcgi_index index.php;
            include fastcgi_params;
        }
    
        # deny access to apache .htaccess files
        location ~ /\.ht
        {
            deny all;
        }
    }
    
  • LeeHLeeH
    edited July 2012

    Interesting. Your config is pretty different from mine (I've detailed mine in a blog post here), but I'm definitely using rewrites.

    I've opened an issue on the Vanilla github page (https://github.com/vanillaforums/Garden/issues/1400) -- would you mind posting there in order to get some traction behind it?

  • BTW, the fix that you posted on Github worked perfectly. Thanks for that!!

  • Not a problem. It's a temporary fix for the issue; it doesn't solve the cause of the problem. I still don't know why the URL without the index.php is returning the entire template. I'm not familiar enough with the internals of Vanilla yet, so someone else may have to answer that. You may want to re-open the issue in the meantime.

Sign In or Register to comment.