Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

karma bank always disabled

edited April 2012 in Vanilla 2.0 - 2.8

I have installed Karma Bank in my forum, and I enable it in plugins page and edit the settings (insert inicial karma, rules, etc..).

But it always appear in the top of the settings page: Status: disabled. How can I enable it?

Thanks

Best Answers

  • x00x00 MVP
    edited April 2012 Answer ✓

    what does it say in your config/config.php file do you have stuff beginning with

    $Configuration['Plugins']['KarmaBank']

    grep is your friend.

  • x00x00 MVP
    Answer ✓

    starting balance is wrong please use a decimal point not comma and be greater than 0. Set it to some value like 0.01.

    I will release now a version that will allow to you set the starting balance to 0.

    grep is your friend.

Answers

  • x00x00 MVP
    edited April 2012 Answer ✓

    what does it say in your config/config.php file do you have stuff beginning with

    $Configuration['Plugins']['KarmaBank']

    grep is your friend.

  • $Configuration['Plugins']['KarmaBank']['Version'] = '0.9.5.5b';
    $Configuration['Plugins']['KarmaBank']['Enabled'] = FALSE;
    $Configuration['Plugins']['KarmaBank']['StartingBalance'] = '0,00';
    $Configuration['Plugins']['KarmaBank']['CommentShowBalance'] = '1';
    

    Thank You for your answer

  • If I manually change the Enabled param to TRUE, it automatically changes to FALSE again...

  • x00x00 MVP
    Answer ✓

    starting balance is wrong please use a decimal point not comma and be greater than 0. Set it to some value like 0.01.

    I will release now a version that will allow to you set the starting balance to 0.

    grep is your friend.

  • Ok thanks!!

  • done

    grep is your friend.

  • FunanaFunana New
    edited June 2012

    Hi @x00, great plug-in!

    I set everything up and it worked, then accidentally put a comma into the starting balance field which gave me an error ("must have a value...").

    Changed the value back to 5 and now the addon keeps showing status as "deactivated".
    I tried to disable and re-enable the plug-in which doesn't help.

    Thanks in advance!

    //Edit: sometimes I should continue trying to solve it by myself instead of posting support requests ^^

    **Solved it: **
    Changed the line
    $Configuration['Plugins']['KarmaBank']['StartingBalance'] = '0,50';
    to
    $Configuration['Plugins']['KarmaBank']['StartingBalance'] = '0.50';

    Gorgsus
  • did you try editing the config.php manually?

    grep is your friend.

  • Edit: sometimes I should continue trying to solve it by myself instead of posting support requests

    that is ok so long as you post the solution.

    grep is your friend.

  • FunanaFunana New
    edited June 2012

    x00 said:
    did you try editing the config.php manually?

    Yes, sir! That's what I did and it worked.

Sign In or Register to comment.