Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Use 'retro' default in Gravatar plugin

edited April 2012 in Vanilla 2.0 - 2.8

If a user doesn't have an avatar, I'd like to use the retro default seen at https://en.gravatar.com/site/implement/images/

I've tried appending the &d=retro to the URL string, but it's still showing me the blue default Gravatar logo.

Any ideas?

Tagged:

Answers

  • AoleeAolee Hobbyist & Coder ✭✭
    edited April 2012

    is this the front page? or the avatar in discussion page?



    Check out my other Plugins here

  • AoleeAolee Hobbyist & Coder ✭✭
    edited April 2012

    try changing this line in plugins/Gravatar/default.php

    //$Url .= '&default='.urlencode(Asset(C('Plugins.Gravatar.DefaultAvatar', 'plugins/Gravatar/default.gif'), TRUE));
    
    $Url .= ' &d=retro';
    


    Check out my other Plugins here

  • I have tried that and it doesn't seem to work. I got it working on another forum using this method. I'm confused why it's not working on these :|

  • AoleeAolee Hobbyist & Coder ✭✭

    check if you have enabled the Gravatar plugin. maybe you have just overlooked it for the particular forum. that's why the code is not being read.



    Check out my other Plugins here

Sign In or Register to comment.