Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Wysiwyg off but can still cut n paste html

edited April 2012 in Vanilla 2.0 - 2.8


New to Vanilla. I am not sure what I am doing wrong in the configuration. I have disabled wysiwyg editors leaving only smilies as option to add more than text to a forum post. However, I am able to cut n paste html directly into the post and the post loads with the html rather than as plain text. Is this correct? How can I prevent this?




  • hbfhbf wiki guy? MVP

    wysiwyg editors only modify behavior by allowing you to see the result of your markup real-time... you can still add html into posts.

    but you can disallow it if you desire.

  • 422422 Developer MVP

    I think you change a conf setting htmlawed or something, ive never done it tho.

    There was an error rendering this rich post.

  • peregrineperegrine MVP
    edited April 2012

    try putting this in the config.php

    $Configuration['Garden']['InputFormatter'] = "Text";

    every post afterwards will not be able to add tags like bold, italic etc.

    to change already posted ones you have to go into the comments table and discussions table and look for the column format

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.