HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Email Notifications Not Being Sent - Config File Setup

edited May 2012 in Vanilla 2.0 - 2.8

We're recently launched a Vanilla 2 forum located at http://TallUnited.com/discuss. I would like to enable email notifications for this site and have not had luck figureing this out.

Info:

  • I've edited the User "Roles & Permissions" to have "AdvancedNotifications" set to "Allow"
  • I've edited the "config-default.php" file to set the following


// Default Preferences
$Configuration['Preferences']['Email']['ConversationMessage'] = '1';
$Configuration['Preferences']['Email']['AddedToConversation'] = '1';
$Configuration['Preferences']['Email']['BookmarkComment'] = '1';
$Configuration['Preferences']['Email']['WallComment'] = '1';
$Configuration['Preferences']['Email']['ActivityComment'] = '1';
$Configuration['Preferences']['Email']['DiscussionComment'] = '1';
$Configuration['Preferences']['Email']['DiscussionMention'] = '1';
$Configuration['Preferences']['Email']['CommentMention'] = '1';
$Configuration['Preferences']['Popup']['ConversationMessage'] = '1';
$Configuration['Preferences']['Popup']['AddedToConversation'] = '1';
$Configuration['Preferences']['Popup']['BookmarkComment'] = '1';
$Configuration['Preferences']['Popup']['WallComment'] = '1';
$Configuration['Preferences']['Popup']['ActivityComment'] = '1';
$Configuration['Preferences']['Popup']['DiscussionComment'] = '1';
$Configuration['Preferences']['Popup']['DiscussionMention'] = '1';
$Configuration['Preferences']['Popup']['CommentMention'] = '1';

  • I've tried to set the above settings in the "config.php" rather than the "config-deault.php"
  • I've tried using both the local mail server and STMP mail. The new user notifications are coming through fine.
  • I believe the user email settings are hidden via CSS and cannot be changed via the user profile. I would like for there to be one set of standard settings for all users.

Questions:

  • Are the settings above supposed to be in the "config.php" or config-default.php" or both?

Support:

  • I would be interested in working with a Vanilla expert on these types of topics. Let me know if you are intererested at jt {at} tall united {dot} com.

Best Answer

  • peregrineperegrine MVP
    edited May 2012 Accepted Answer
    $Configuration['Garden']['Email']['UseSmtp'] = 
    $Configuration['Garden']['Email']['SmtpHost'] = 
    $Configuration['Garden']['Email']['SmtpUser'] = 
    $Configuration['Garden']['Email']['SmtpPassword'] =
    $Configuration['Garden']['Email']['SmtpPort'] = 
    $Configuration['Garden']['Email']['SmtpSecurity'] =
    

    might be one of these settings. just guessing

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    422justinsthompson

Answers

  • peregrineperegrine MVP
    edited May 2012

    click on your name to go to the profile.

    click on my preferences - it is an individual option for all users
    do you see "my preferences"?

    you shouldn't change config-default.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    justinsthompson
  • @peregrine: thanks for the feeback. I believe the the "my preferences" section of the profile has been hidden by CSS. Is there a way to have a master default setting for all users that is configurable via the admin panel?

  • peregrineperegrine MVP
    edited May 2012

    is view and edit profiles checked for members in your dashboard - if not try checking them. i would restore config-defaults.php to its original form.

    and I quote:

    Default Email Preferences
    
    The following config settings set the default preferences for email. These are the preferences that users set in their profile.
    
    $Configuration['Preferences']['Email']['ActivityComment'] = TRUE; Notify me when people reply to my wall comments.
    
    $Configuration['Preferences']['Email']['AddedToConversation'] = TRUE; Notify me when I am added to private conversations.
    
    $Configuration['Preferences']['Email']['BookmarkComment'] = TRUE; Notify me when people comment on my bookmarked discussions.
    
    $Configuration['Preferences']['Email']['CommentMention'] = TRUE; Notify me when people mention me in comments.
    
    $Configuration['Preferences']['Email']['ConversationMessage'] = TRUE; Notify me of private messages.
    
    $Configuration['Preferences']['Email']['DiscussionComment'] = TRUE; Notify me when people comment on my discussions.
    
    $Configuration['Preferences']['Email']['DiscussionMention'] = TRUE; Notify me when people mention me in discussion titles.
    
    $Configuration['Preferences']['Email']['WallComment'] = TRUE; Notify me when people write on my wall.
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    justinsthompson
  • @peregrine: thanks again for the response. So in my case, at least at the moment, the user is not able to set these settings in their profile since it is hidden via CSS. In that case, they would be setup on the default configuration of these settings and they would be unchanged. Is there a location where I determine what these default settings are for all new users?

  • peregrineperegrine MVP
    edited May 2012

    In your first message - you set them to get e-mail from anything essentially. But the changes only occur for new users. It doesn't change past users. you would need to change that in the database.

    Config defaults - sets them - you theoretically leave that alone (so you can't mess things up).

    and override in config.php

    in this case

    // Default Preferences
    //checked true
    $Configuration['Preferences']['Email']['ConversationMessage']   = '1';
    $Configuration['Preferences']['Email']['AddedToConversation']   = '1';
    $Configuration['Preferences']['Email']['BookmarkComment']       = '1';
    //checked false
    $Configuration['Preferences']['Email']['WallComment']           = '0';
    $Configuration['Preferences']['Email']['ActivityComment']       = '0';
    $Configuration['Preferences']['Email']['DiscussionComment']     = '0';
    $Configuration['Preferences']['Email']['DiscussionMention']     = '0';
    $Configuration['Preferences']['Email']['CommentMention']        = '0';
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    justinsthompson
  • I suppose you could change the user table - column preference and make them all null and the that would give everybody the default preference you set in your config.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    justinsthompson
  • Alright, so I changed the config.php to the values above. Also went into the database via phpmyadmin and verified the value of the "preferences" in gdn_user's to NULL. All of the "member" users were already at NULL, only the Admin had a non-NULL value there. Emails are still not being sent. Maybe it's an issue with the outgoing email settings, but I do receive the new user notification emails...

  • peregrineperegrine MVP
    edited May 2012 Accepted Answer
    $Configuration['Garden']['Email']['UseSmtp'] = 
    $Configuration['Garden']['Email']['SmtpHost'] = 
    $Configuration['Garden']['Email']['SmtpUser'] = 
    $Configuration['Garden']['Email']['SmtpPassword'] =
    $Configuration['Garden']['Email']['SmtpPort'] = 
    $Configuration['Garden']['Email']['SmtpSecurity'] =
    

    might be one of these settings. just guessing

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    422justinsthompson
  • Yeah buddy, that's what it was. I had "user" in the 'SmtpUser' field instead of "[email protected]". Thanks a lot for the support.

    422
  • peregrineperegrine MVP
    edited May 2012

    glad I could help and glad you "liked" them. I'm a like hog.

    @underdog - maybe [documentation]

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    422justinsthompson
  • I need to do the same thing... I got a little confused on exactly what I need to do reading this post. This should definitely be in a doc somewhere. So far I changed all these to "1"
    // Default Preferences $Configuration['Preferences']['Email']['ConversationMessage'] = '1'; $Configuration['Preferences']['Email']['AddedToConversation'] = '1'; $Configuration['Preferences']['Email']['BookmarkComment'] = '1'; $Configuration['Preferences']['Email']['WallComment'] = '1'; $Configuration['Preferences']['Email']['ActivityComment'] = '1'; $Configuration['Preferences']['Email']['DiscussionComment'] = '1'; $Configuration['Preferences']['Email']['DiscussionMention'] = '1'; $Configuration['Preferences']['Email']['CommentMention'] = '1'; $Configuration['Preferences']['Popup']['ConversationMessage'] = '1'; $Configuration['Preferences']['Popup']['AddedToConversation'] = '1'; $Configuration['Preferences']['Popup']['BookmarkComment'] = '1'; $Configuration['Preferences']['Popup']['WallComment'] = '1'; $Configuration['Preferences']['Popup']['ActivityComment'] = '1'; $Configuration['Preferences']['Popup']['DiscussionComment'] = '1'; $Configuration['Preferences']['Popup']['DiscussionMention'] = '1'; $Configuration['Preferences']['Popup']['CommentMention'] = '1';

    Is that correct?

    Also, this is my default mail settings in the config.php

    $Configuration['Garden']['Email']['UseSmtp'] = FALSE; $Configuration['Garden']['Email']['SmtpHost'] = ''; $Configuration['Garden']['Email']['SmtpUser'] = ''; $Configuration['Garden']['Email']['SmtpPassword'] = ''; $Configuration['Garden']['Email']['SmtpPort'] = '25'; $Configuration['Garden']['Email']['SmtpSecurity'] = '';

    What do I need to put there?

    Is there anything else I need to change? I am really confused as to why this isn't easier to edit...

  • see dashboard settings for - outgoing mail.

    We will attempt to use the local mail server to send email by default. If you want to use a separate SMTP mail server, you can configure it below.

    the above should fill in the SMTP statements.


    if you don't know what your mail server is - contact your host provider - we can't answer that for you.

    also read the current documentation on configuration

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.