Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.


Hi - I am new to this site and indeed Vanilla (so apologies if this is a post that is answered elsewhere - as I have tried to look for it). I run a Rapidweaver site and I was able to install Vanilla (and change the 'Howdy' message) with no problems. However when I try and register a userid I get the 'could not open socket' message after entering the rCaptcha checks. I asked my host if they are blocking these requests and they said 'probably'. They also sent me this response:

"Hi,it could be a number of things, unfortunately without in depth knowledge of how the google code works I can only guess. The most likely explanation I can think of is that the recaptcha uses curl to access scripts on googles server which would be blocked by our security policies. If this is the case the only way round it would be to host the entire recaptcha code in your ftp space."

Anyone else had this problem ? Any suggestions as to how I get around this ? (or even host the rCaptcha code on my ftp space ?)




  • Options

    actually it uses fsockopen rather than curl.

    I would be surprised if a host banned curl and not fsockets. Most host have allow some fsockets, turn allow_url_fopen off, and allow some curl.

    grep is your friend.

Sign In or Register to comment.