Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Parse error on upgrade

impuwatimpuwat New
edited May 2012 in Vanilla 2.0 - 2.8

Getting a parse error after upgrading from a previous version of 2 to 2.0.18.4. Upgraded on the server with simple scripts.

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in ...../library/core/class.pluginmanager.php(766) : eval()'d code on line 5

Another install of 2.0.18.4 is working perfectly on a different subdomain on the same server. Any ideas?

Answers

  • Options

    Open /library/core/class.pluginmanager.php and look for strange text, code, etc.

    There was an error rendering this rich post.

  • Options

    I've downloaded vanilla and uploaded a different new version of class.pluginmanager.php and have the same issue. So why would I have an error? I'm not seeing an error in the text, etc., but don't have much knowledge in the area. And why would I have a error in a script that no one else has?

  • Options

    Solved

    I deactivated all my plugins before upgrading. After upgrading had the problem described above. Removed all plugins from server and issue disappeared. Have been adding them back and no problems detected

  • Options
    422422 Developer MVP

    Good job.

    So the moral of the story, deactivate plugins. Upgrade and reactivate one at a time. Testing after each activation.

    There was an error rendering this rich post.

Sign In or Register to comment.