Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Conversation Box too Small

edited June 2012 in Vanilla 2.0 - 2.8

Hi In the conversation / message form the add message text box is too small and doesnt auto resize so you cannot see what you are typing. I have tried CSS edits but the form seems to have an in-html style as below

Do you know where i can change this?


  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Can't you drag and resize using the bottom right corner?

  • Options

    No it won't even let me do that which is odd

  • Options

    Think javascript / browser issues or issues with page speed plugins (if you have any).

    Try with all browsers and tell us which plugins you use for editor (tinyMCE? buttonbar?) and any other plugins.
    Any errors in fireBug?

    There was an error rendering this rich post.

  • Options

    No errors, I use cloudflare which could cause a problem. I use WYSIWYG (CLEditor) but it doesnt show up on conversations. I have no page speed plugins enabled as minify messes up my theme.

    I am also running Vanilla Bootstrap

    <textarea id="Form_Body" class="MessageBox" cols="100" rows="6" name="ConversationMessage/Body" style="overflow: hidden; word-wrap: break-word; max-height: 38px; min-height: 38px; height: 38px; display: block;"></textarea>

    Here is the code for the textarea

  • Options
    422422 Developer MVP

    Remove height. Attribute from css.

    There was an error rendering this rich post.

  • Options

    422 said:
    Remove height. Attribute from css.

    Thats the thing, i cannot find which file that html is.

  • Options
    KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    VanillaBootstrap uses the autosize jQuery plugin which disables the resizing function (autosize automatically resizes textareas). Simply remove the autosize call in the default.master.tpl file and you should be good to go :)

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

Sign In or Register to comment.