Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Themes and Locales not showing (even if I delete the defaults)

edited June 2012 in Vanilla 2.0 - 2.8

Hey!

I just installed Vanilla and have a little problem that I can't really work out a solution for: Although I've put the German locale in the right folder and put a custom theme in the right folder, they won't show up, ever.

I even deleted the defaults to make sure everything is alright. Which it isn't tbh: the default is still being shown when I deleted the whole theme folder (bit drastic, I know)...

So the theme I want to use is /forum/themes/DarkMist. I checked for the about.php which is there but I cannot access it directly. Which makes me wonder what I've done wrong.

The forum itself can be found at http://www.gameradar.de/forum/ but you will see that it's a.) the default theme and b.) in English.

When I go to Dashboard, I don't even see a new theme nor a new locale. The three standards (default, Embed and mobile) remain in my dashboard - even if I delete the whole theme folder.

Does anyone know what the problem could be?

Thank you,
P.

Best Answers

  • Options
    x00x00 MVP
    edited June 2012 Answer ✓

    The theme is either not there, or the permissions of the folder are such that it won't show up

    if it did
    http://www.gameradar.de/forum/themes/DarkMist/about.php

    or

    http://www.gameradar.de/forum/themes/darkmist/about.php

    would show a blank page rather than Not Found.

    like

    http://www.gameradar.de/forum/themes/default/about.php

    I would also check that you are putting the themes in the right folder. You wouldn't expect if you delete embed an mobile for them to show up.

    that is my best best. Double check the folder.

    grep is your friend.

  • Options
    x00x00 MVP
    Answer ✓

    first of al never 777 everything. 777 is rarely needed, if you set your server user/groups properly.

    is it in /forum/themes/DarkMist ?

    set the permission on the folder and also the files to 755, particularly the about.php.

    like I said the embed theme does not exist out of the themes folder, so if you have deleted it and it is still showing up you are in the wrong path.

    Other possibility is memcache, are you using it or other caching?

    Just for good measure delete the .ini files in cache.

    grep is your friend.

  • Options
    peregrineperegrine MVP
    Answer ✓

    there is a cache folder that you should be able to access.

    delete all the ini files in /vanilla/cache/*.ini and see if that helps.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Answers

  • Options
    x00x00 MVP
    edited June 2012 Answer ✓

    The theme is either not there, or the permissions of the folder are such that it won't show up

    if it did
    http://www.gameradar.de/forum/themes/DarkMist/about.php

    or

    http://www.gameradar.de/forum/themes/darkmist/about.php

    would show a blank page rather than Not Found.

    like

    http://www.gameradar.de/forum/themes/default/about.php

    I would also check that you are putting the themes in the right folder. You wouldn't expect if you delete embed an mobile for them to show up.

    that is my best best. Double check the folder.

    grep is your friend.

  • Options

    I double-checked the folder...DarkMist is in /themes/ - top-level and not deeper down.

    I set the permissions to 777 to give the system all and each possibility so permissions can't be the problem.

  • Options
    x00x00 MVP
    Answer ✓

    first of al never 777 everything. 777 is rarely needed, if you set your server user/groups properly.

    is it in /forum/themes/DarkMist ?

    set the permission on the folder and also the files to 755, particularly the about.php.

    like I said the embed theme does not exist out of the themes folder, so if you have deleted it and it is still showing up you are in the wrong path.

    Other possibility is memcache, are you using it or other caching?

    Just for good measure delete the .ini files in cache.

    grep is your friend.

  • Options
    edited June 2012

    It is there but it is not there, too. This is some strange stuff. I found that files are not showing on the net although they are on the ftp. I found this out because I uploaded pictures to show that I placed it all right and those pictures are not showing.

    So it seems to be a caching problem. Funnily enough: everything is right in my ftp window, just not showing.

    I don't have root access, which caching problems could this be and is there a work-around?

    It seems to be a problem after update of the server system :(

    And: I only did a temp 777 of course ;)

  • Options
    peregrineperegrine MVP
    Answer ✓

    there is a cache folder that you should be able to access.

    delete all the ini files in /vanilla/cache/*.ini and see if that helps.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Actually it was something completely different and my hoster is to blame (he had a mirrored backup that I had access to but that was not the live server).

    So I am very sorry to have bothered you all. I'm now starting to get the forum running :)

    P.

Sign In or Register to comment.