Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the eng

I noticed the following error on my discussions page. Not sure what it was about.

event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.

Is anyone else getting this?

Comments

  • Yes, I also noticed this recently in Chrome. The warning seems to be thrown on a mouseMove event, ie. hundreds of times per page.

    It's apparently a jQuery/WebKit interaction, and there are a number of discussions on it if you search for this message. Some say that jQuery 1.7 fixes this problem (my Vanilla seems to jQuery 1.6.2), but some say it doesn't.

    In any case, I haven't bothered to investigate further as it doesn't seem to cause any problems.

Sign In or Register to comment.