Please upgrade here. These earlier versions are no longer being updated and have security issues.

Markdown instead of Simple HTML

This discussion is related to the Button Bar addon.
zaneperryzaneperry New
edited June 2012 in Vanilla 2.0 - 2.8

I am like everyone else and want to use the button bar with Markdown just as vanillaforums.org community has. I installed button bar and notice it uses simple html. How do I make it use Markdown? I tried installing the Markdown plugin but the zip file only has one file and unzipping it to the plugin directory does nothing.

Also, the comment bar looks different and I see no options to change. I would like the bar instead of the curve buttons

Thank you!

Tagged:

Comments

  • there is no need to install a plugin

    just set

    $Configuration['Garden']['InputFormatter'] = 'Markdown';

    grep is your friend.

  • TimTim Operations Vanilla Staff

    The bar 'look' is done with CSS. You have full control over that.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • awesome! Thanks :)

  • I added

    $Configuration['Garden']['InputFormatter'] = 'Markdown';

    to /conf/config.php

    but the buttons still insert html and the bottom still says

    You can use Simple HTML in your post.

    Did I do something wrong?

  • I can't figure this one out. Everything I have found online says that adding that line to /conf/config.php should set it to use Markdown.

  • Tim said:
    The bar 'look' is done with CSS. You have full control over that.

    It appears you guys have made some modifications to the plugin as well. The BarWrap div does not appear standard.

  • GuppethGuppeth New
    edited June 2012

    One thing I've noticed is that changing the input formatter in config.php only affects new discussions. To change an existing discussion to use markdown for new replies I had to play around with the database. Presumably this is to prevent the formatting of old discussions from breaking.

    So if you create a new discussion it should use your setting, but if you reply or edit an existing discussion it should use the setting that was set when that discussion was created.

  • That is it! Thank you :)

  • It is not that, it is to allow different formatting on different post, which is theoretically possible.

    grep is your friend.

  • To change an existing discussion to use markdown for new replies I had to play around with the database.

    What is the process to make a previous post Markdown instead of Simple HTML?

  • use phpmyadmin and look in comment and discussion tables - see the format column and change accordingly.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Thx!

  • e.g. - change the limit

    UPDATE vanilla.GDN_Comment SET Format = 'Html' WHERE GDN_Comment.Format <> 'Html' LIMIT 1;

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Pamela
  • zaneperryzaneperry New
    edited June 2012

    Not sure I follow that. I changed all of the Html's to Markdown appears to work.

    Strange thing though. Clicking the image button does not create the correct markdown. It creates !()instead of the correct ![](). What could cause that?

  • peregrineperegrine MVP
    edited June 2012

    on mine it produces![]() . Did you modify the buttonbar? maybe download it again if you messed with it.
    is this the only line with 'InputFormatter in your config file.

    $Configuration['Garden']['InputFormatter'] = 'Markdown';

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • zaneperryzaneperry New
    edited June 2012

    I just deleted and reinstalled button bar. The button still posts !(). When I manually create ![]() it works as expected and displays the image. Can't figure what I did wrong to break it.

  • zaneperryzaneperry New
    edited June 2012

    Yes, that is the only line with InputFormatter.
    All other buttons work. Correction. Strike out does not do as this site does either with
    <del>text</del>

    The button on my site enters -text-

    Testing this forum

    Very strange. I created another question for this issue.

Sign In or Register to comment.