HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] Not working with 2.1 - is an update planned?

This discussion is related to the I Like This ( Plugin ) addon.
whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
edited July 2012 in Vanilla 2.0 - 2.8

This is a great plugin, but it doesn't seem to work with 2.1.

The 'Like' span doesn't get loaded to the page.

Can we hope for an update?

Tagged:

Comments

  • First get out some details, por-favor, FireFox? FireBug? jQuery error?

  • 422422 Developer MVP

    May well be worth setting a 2.1 forum up @underdog or its gonna get messy

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @UnderDog

    I'm using Firefox.

    There is no error reported in the Error Console, the Like link simply doesn't appear on the page, as the span class does not get loaded.

    I did try to have a look at the php file, and compare it with the Quotes plugin one (which does work in 2.1) but I'm out of my depth, tbh.

  • peregrineperegrine MVP
    edited July 2012

    I messed around with it. hbf programs circles around me so he might have better ideas.

    But if you want to give it a try, it seemed to work for me.

    1) I changed every reference (there are a number of them.

    &$Sender
    
    to 
    $Sender
    

    2) I modified this and it seemed to work but it may not be the best way and may even break something around line 225.

         $Sender->Options .= '<span class="Like">';
          $Sender->Options .= $this->FormatLikes($Likes, $Url, $UID, $Self);
          $Sender->Options .= '</span>';
    
        to 
    
         echo '<span class="Like">';
          echo $this->FormatLikes($Likes, $Url, $UID, $Self);
          echo '</span>';
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDogwhu606fh111
  • you could also replace part 2 with this

     //  $Sender->Options .= '<span class="Like">';
      //  $Sender->Options .= $this->FormatLikes($Likes, $Url, $UID, $Self);
      //  $Sender->Options .= '</span>';
    
        $LikeDisplay = $this->FormatLikes($Likes, $Url, $UID, $Self);
    
       echo <<<LIKE
          <span class="Like">$LikeDisplay</span>
    LIKE;
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    whu606fh111
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @Peregrine

    Thanks for that - you are, as always, a star.

    I shall give that a crack.

    SheilaUnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @Peregrine - yep, that certainly did the trick!

    Thank you so much.

    UnderDogperegrine
  • glad it worked. thanks for reporting back.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDogfh111
  • fh111fh111 Vanilla Padawan ✭✭

    nice, thanks @peregrine

    UnderDogperegrine
  • hbfhbf wiki guy? MVP

    @whu606

    The plugin has been updated to include the fix listed here, along with some additional 2.1 compatibility updates.

    I suggest downloading Version .6 for anyone running 2.1

    BTW - the fix that peregrine provided removes the code which adds like to the options menu, which in 2.1 is the little gear drop down and not a good way to display something like this.

Sign In or Register to comment.