Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Error uploading avatar or attachments: "The upload was stopped by extension"

AndRosAndRos New
edited July 2012 in Vanilla 2.0 - 2.8

Hi i'm new to Vanilla. I'm buildig up my forum but i've an issue that i can't solve. Do many search and trick but nothing. I'm unable to upload any file (included avatar).

Actually i'm working on a fresh new installation of vanillaforums-Garden-Vanilla_2.0.18rc3-2249-g6dc6f69 hosted on
Permission chmod 777 to "uploads, conf, cache" done

In my first attempt with cPanel and installatron i was fully able to upload avatars and attachments with "File Upload plugin" in

I don't kwnow what happened, even if i try an "installatron installation" of the issue now is the same.

Before every installation i've deleted ALL files in public_html folder.
I'm using Ubuntu, FileZilla and a broadband connection.


  • Options

    Also: phpinfo returned upload=yes...
    chmod 777 in upload are in all files and subdirectory

    i've created a test user (member)
    name: test
    pass: 1234

  • Options

    No one have idea of what happened?
    Tried another installation of vanilla, this time the develop... oh yes very cool features.... i love this platform but i can't even think to start a community if i can't allow avatars! no one have idea? Tried several installation and several way to do it (included automatic installation with installatron). The first attemp, repeat, was fully successiful with upload. I decided to switch to a newer version becouse "don't follow" option didn't work... but.... now i'm in trouble again! :(

  • Options
    ToddTodd Chief Product Officer Vanilla Staff

    This message has to do with your server configuration. Doing some googling (which you really should also try) I found that you can try adding the following to your .htaccess file:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
  • Options

    Nothing to do.
    I've tried also a fresh netsons hosting, fresh vanilla installatron install.... nothing.

  • Options

    Possibly is a "Netsons" issue not Vanilla.
    I've installed myBB and i'm unable to upload the same.
    Tanks for help now i'm wondering how to solve....

  • Options
    SheilaSheila ✭✭
    edited July 2012

    @AndRos You might wanna contact your ISP in case they are willing to fix the issue at their end. Worth asking :)

  • Options

    99% a netsons issue.
    Opened a "ticket" for assistance. I've also tried another site (not mine) hosted at and TA-TAN no way to upload avatar or attachments!
    I could say "solved"

  • Options

    AndRos said:
    I could say "solved"

    Thanks for the update. Let us know how Netsons resolves your ticket and when you can upload again, I'll mark it as 'solved', ok :-)

    There was an error rendering this rich post.

  • Options

    I don't kwow "how" but Netsons solved the problem. It was a php "error 8" on the server side. Now all is ok. :D

Sign In or Register to comment.