Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My HTML display incorrectly ( in body, doctype missing)

user38911user38911 New
edited July 2012 in Vanilla 2.0 - 2.8

Hi guys,
My vanilla forum display a bit weird.
In Internet explorer it runs in Quirk mode and the site looks terrible
I figured out that i need to add the doctype.
So i added it in the default.master.tpl.
Is it the correct place to add it in? as it doesn't show up on the site even though i already added.

The other issue i found is that the < title > element is located in the < body > element instead of the < head > element
Any comment on why it misplaced?

I've attached a screenshot from the inspector element if that would help.

http://s13.postimage.org/dsra43brr/Untitled_1.png
Thanks.

Comments

  • It could be your theme, I notice you have disabled character encoding.

    grep is your friend.

    user38911
  • chem7stry said:
    I figured out that i need to add the doctype.
    So i added it in the default.master.tpl.
    Is it the correct place to add it in? as it doesn't show up on the site even though i already added.

    The files are probably cached by Smarty so you need to clear the Smarty cache and then check again whether your doctype is shown.

    What is the address of your website? Can we see it or is it on your local PC?

    user38911
  • thanks, please kindly take a look
    http://www.mobizmarket.com/forum/

    even if i changed to other theme. it still the same

  • i looked into my config-defaults.php
    this line
    $Configuration['Database']['CharacterEncoding'] = 'utf8';
    i understand that it is enabled.

  • x00x00 MVP
    edited July 2012

    it is generally good to do validation

    http://validator.w3.org/check?verbose=1&amp;uri=http://www.mobizmarket.com/forum/

    You need to save the files without BOM (this a common mistake with notepad)

    grep is your friend.

    UnderDog
  • Right to the point.
    Just to be useful for later viewers. x00 comment fixed my issue
    I searched through the file and found out that my locale file 'captured.php' was saved in UTF-8 mode
    When i changed it to UTF-8 without BOM, it works perfectly.

    Thanks million times

    UnderDog
Sign In or Register to comment.