Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] All forum content missing after upgrading

edited July 2012 in Vanilla 2.0 - 2.8

I upgraded from v1.1.4 to v2.0.18 but now all the content and users etc seems to be missing.

I followed the instructions here, which say simply to overwrite the existing files:

I have since found these contradictory instructions which say not to overwrite the conf/, cache/, uploads/, custom themes/and custom plugins/:

I have reinstated the old uploads/ directory from my backup.

The old messages are still in the database, but not the old users. Should I ask the web host to replace the database with the backup of the old one?

Then how do I make the new installation of Vanilla see that content?



  • You are upgrading from version 1 to version 2 so I don't think that will apply.

    Look 1 more time in the database to see if there are any users in there (at least 1 of course, but beside that single user, how many other users.

    Prepare to restore the backup you created before you started (or let your webhost restore that database backup.

    The way I would do it is:

    • Backup
    • Backup
    • Backup
    • Use either the Porter Plugin or the Porter Plus plugin to export the data from Vanilla 1
    • Install Vanilla 2.0
    • Import the file you created when you exported from Vanilla 1
    • Backup
    • Backup
    • Backup

    There was an error rendering this rich post.

  • ToddTodd Chief Product Officer Vanilla Staff

    Vanilla 1 and Vanilla 2 are completely different animals, you can't just point Vanilla 2 at your old database. What you need to do is grab the Vanilla Porter and export your Vanilla 1 data and then import it to Vanilla 2.

  • nicepaulnicepaul
    edited July 2012

    Thanks UnderDog, and thanks Todd.

    Those instructions on Google Code say "Upgrading from 1.1+", and I was upgrading from 1.1.4 so I figured that was the correct place to look. If it's the wrong place to look, there should be a note on that page saying so, as that's what's caused these problems.

    Same goes for this page, which is where I followed the link to the Google Code page from:

    There's also this page, which seems to be the latest but doesn't explain what to do with the conf/ and uploads/ folders it told you to back up:

    Thanks for the tip about the Porter plugin. Once I have the database backup in place, how do I run the Porter plugin given that I only have the old database, not an installed and running version of Vanilla 1.1.4?

    Worse case scenario, is there a copy of Vanilla 1.1.4 I can download from somewhere to reinstall? I have found Vanilla 1.3, but will my database work with that without going through the 1.1.4-1.3 upgrade process?


  • Found a copy of Vanilla 1.1.8 at the link below (labelled as 1.1.4). Shall I install that in the same location that it use to be, before restoring the database backup? Will the 1.1.4 database work with 1.1.8?

    Thanks again!


  • Hooray! I fixed it :)

    Turned out the database tables were there, but I was looking in the wrong place. I moved the old forum back to it's original location (I had only moved it, not removed it) and managed to use the Porter addon.

    Thanks for all your help.


  • I see you're using awesome! Please make regular backups ok, and doublecheck whether everything is working the way you're expecting it to work.

    There was an error rendering this rich post.

  • Just attempted an upgrade from 2.0.?.? to and have completely messed things up. I made a backup of my vanilla install by renaming the vanilla folder (this is what I did last time) I then copied the folder and named it vanilla again. I have overwritten all the files using "Vanilla-core-" but now when i go to my forum home page i get this error message :- "Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /homepages/34/d260127691/htdocs/vanilla/index.php on line 48" In the process I seem to have lost my backup folder too. Can somebody please guide an idiot in the right direction.

  • Probably a good idea not to add to a discussion that already says solved. With a completely new issue. Start a new one.

    meanwhile - have you been modifying index.php by chance

    syntax error is usually a result of a user (you) modifying a file

    look at line 48 or recopy index.php from the vanilla core zip files.

    also read

    also read

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Thank you Peregrine. I will read the above linked info and if necessary start a new discussion. Thanks again. Mike

Sign In or Register to comment.