HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Remove querystrings from URLs

nicepaulnicepaul
edited July 2012 in Vanilla 2.0 - 2.8

I have URLs like this:
http://www.video125.co.uk/forum/index.php?p=/discussion/552

Shorter URLs work, but because internally Vanilla is linking to the longer URLs, these will never actually be used:
http://www.video125.co.uk/forum/discussion/552

How do I get Vanilla to use the cruft-free URLs when linking to discussions etc?

thanks,
Paul

Best Answers

  • x00x00 MVP
    Accepted Answer

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    .htaccess just handles the redirect, they don't don't tell vanilla to use friendly urls.

    grep is your friend.

    Kasper
  • x00x00 MVP
    edited August 2012 Accepted Answer

    which sets that for you.

    grep is your friend.

Answers

  • I found an option in the Formatting plugin to 'use pretty URLs'.

  • KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    ...for this to work out of the the box, you'll need to include the .htaccess file in your installation too. You can't see it unless you've enabled viewing hidden files though. I think this is a common error :-)

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

  • I had included the .htaccess file. In fact, the latest version of Vanilla won't let you get past the setup screen without it.

  • 422422 Developer MVP

    nicepaul said:
    I had included the .htaccess file. In fact, the latest version of Vanilla won't let you get past the setup screen without it.

    Which version are you referring to by, latest version ?

  • The version I downloaded from the website yesterday. 2.0.18.4

  • x00x00 MVP
    Accepted Answer

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    .htaccess just handles the redirect, they don't don't tell vanilla to use friendly urls.

    grep is your friend.

    Kasper
  • As I mentioned above, I fixed this using an option in the Formatting plugin to 'use pretty URLs'.

    thanks,
    Paul

  • x00x00 MVP
    edited August 2012 Accepted Answer

    which sets that for you.

    grep is your friend.

Sign In or Register to comment.