Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Embed Problems - Vanilla, Wordpress 3.4.1, WP Vanilla Forums Plugin 1.1.12

davey_hdavey_h New
edited August 2012 in Vanilla 2.0 - 2.8

I posted the below question on solved thread but saw after that some of the versions are slightly different. I'm not sure if a solved thread will get answered either so thought it best to start over.

I'm not sure if the version differences would cause any issues and don't know how to update Vanilla, it doesn't seem to give any update info in the dash.


It seems that I have picked up the idiot stick for this issue now. I've been through these instructions 20 times and the forum still will not embed into the WP page. I have the WP forum page set to /forum and put this into the WP Vanilla embed set up. I just get a message saying no Vanilla forum found at this URL.

I have seen a discrepancy between Vanilla and WP in the path to embed the set up: (code shortened to text for ease of posting) WP says the path ending is: ./forum/js/embed.js

Vanilla says the path is: ./forum/plugins/embedvanilla/remote.js

I've tried both and a few wild guesses with no joy. The WP page just redirects to: ./forum/index.php?p=/discussions

I must be doing something wrong but can't see it?

Any clues please?

While I am writing I have noticed that the WP Vanilla plug ins also cause a significant page load delay. Of course this may be related to the embed problem I do not know.

Any help on this please?


  • Options

    Any ideas anyone please? Anyone else still getting a problem with the embed?

  • Options
    422422 Developer MVP

    got a link

    There was an error rendering this rich post.

  • Options

    Hiya, thanks for posting. I think you mean a link to the site. But to cleat I'll post the whole set up.

    The url is a relaunch of a genealogical website which once had a popular forum.

    I am using WP 3.4.1 and the WP forum page is here:
    That link from the site take you to an unembedded Vanilla forum

    In my Vanilla install under embed I have the Embed-Friendly theme and the js that Vanilla tells me to use is:

    As previous instruction I have followed on here in WP I have installed the Vanilla embed plugin which is 1.1.12. I then created a page called /forum and inserted the Vanilla js into the HTML:

    In the WP plugin intergration it gave a slightly different js path.

    I changed this to the Vanilla given path I put the url in the plugin and saved:

    Finally I went to the set up and put the url in there as well; but I am getting an error message that it can't find the forum install.

    as far as I can see I have followed the instruction on here in that other thread. I have had no joy getting this embedded and have tried using the other WP path as well.

    This will hold up the relaunch which I am hoping to release at the end of the month so if anyone can spot my FUBAR or knows what is going wrong please can you let me know.

    Kind regards and thanks

  • Options
    jrocjroc New
    edited August 2012

    I don't think you can use the same url for the wordpress page for the embed and the unembedded vanilla forum. That could be the problem. Try changing the permalink for the wordpress page to something other than /forum or rename the vanilla folder to something other than forum.

  • Options

    Thanks for your suggestion of changing the permalink to be different to the Vanilla install. It does make sense thinking about it.

    The path to the js is to the actual vanilla install and the path to
    display it in WP can't be the same.

    So, I changed the permalink to FORUMS and updated this in the WP plug in
    where it asks for the WP vanilla location.

    It still tells me that it can't find the install. Have tried both the WP
    js path and the Vanilla path.

    If I had any hair I'd be pulling out out right about now!


  • Options

    That's weird. How come you aren't using the latest versions of Wordpress and Vanilla? If you pm me the details I can take a quick look if you'd like.

  • Options

    Thanks jroc, PM sent.

    BTW; item for mods to take up and pass on maybe, although I don't know how to flag this.

    On searching the docs I found a link that is no longer valid.

    see and under Features & Addons > Embed Vanilla the link returns:

    Addon not found.
    The page you were looking for could not be found.

  • Options

    jroc said:
    How come you aren't using the latest versions of Wordpress and Vanilla?

    Wordpress does its own plugin and version updates and is up to date as far as I know. My Vanilla install is a little out of date and I have downloaded last version to change - shame there is no Vanilla auto updater like WP. Manual updates are a painful process!

  • Options

    Sorry yeah just vanilla is out of date, not sure why I thought your wordpress was out of date as 3.4.1 is the latest version.

  • Options
    davey_hdavey_h New
    edited August 2012

    I updated Vanilla. Must say the how to update instructions in the Docs are very vague! No clear guide on what files needs replacing and what can be left.

    Anyway the update didn't solve the problem. I have a strong feeling that the error is due to the WP plug in not finding the vanilla install since the error message is: Couldn't find a Vanilla Forum at this url :/

    Looking at the plugin I see that this validation code is handled by admin.php here:

    /* Validate a vanilla forum url */
    validateUrl = function() {
    var validateUrl = $('input.InputBox').val();
    if (validateUrl == '') {

        $('.Validated, .Invalid').hide();
          url: '<?php echo site_url('wp-admin/admin.php?page=vf-admin-handle&vanillavalidate='); ?>'+validateUrl,
          success: function(data) {
             if (data.indexOf('http://') == 0) {
             } else {
          error: function(data) {
          complete: function() {
        return false;


    <?php _e('Vanilla Forums Setup'); ?>

    Use this page to configure your Vanilla Forum to work with WordPress.

    <?php if ($url == '') { ?>

    Don't have a Vanilla Forum yet?

    Get one in under 60 seconds!
    <?php } vf_open_form('url-form'); ?> Enter the full url of your Vanilla Forum: " value="<?php echo $url; ?>" class="InputBox" /> ... Validated :) Couldn't find a Vanilla Forum at this url :/ eg.

    " /> " />


    But I can't see any obvious problems.

    I'm not sure what you wanted to look at to see I have posted the install flow above. Please let me know what you wanted to look at.

    I think the next stage will be to delete the plugins and try again.


  • Options

    That script attach didn't work well!!

  • Options
    jrocjroc New
    edited August 2012

    could try getting rid of the / on the end of the forum url

    delete the .ini files in the vanilla cache folder

    are you using any wordpress cache plugins?

    any pages in the trash with /forum permalink?

    does you server have cURL enabled?

  • Options

    The / was inserted by the plugin.
    BUT NO MATTER it is fixed!
    From the instructions I was using both plugins, Vanilla and WP. I deactivated the WP one and used the Vanilla on its own and BINGO - it worked.

    Thanks for your time and indulgence.

  • Options

    No worries, nice work!

  • Options

    Thanks, I think this was a case of a clash of the plugs in. Although I am confused as to why that other thread stated to use them both... unless I misunderstood it of course. But solved.

Sign In or Register to comment.