Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

RSS broken -- can't figure it out!

Bud1Bud1 New
edited August 2012 in Vanilla 2.0 - 2.8

I'm using Version When clicking the RSS feed buttons in the Categories section, I get the following error:

XML Parsing Error: XML or text declaration not at start of entity
Line Number 2, Column 1:<?xml version="1.0" encoding="utf-8"?>

I've tried disabling my plugins one at a time, but that doesn't help. I have searched the error, and it seems like it's the line break at the start of the RSS file causing this, but I can't figure out where to go to prevent it from being generated. The entire content of the forum category is there in the source of the file, so there's no issue there; it's just not being shown owing to this error. Any ideas on where I should look to fix this?


  • 422422 Developer MVP
    edited August 2012

    Rss and xml are really code finnercky. Try version 2.0

    There was an error rendering this rich post.

  • The embarrassing thing is I don't know where to find that to change; I've done a search on my entire forum folder and it won't show up. Do you know where I should look?

  • 422422 Developer MVP
    edited August 2012

    Im mobile so no idea, will look in the morning tho.

    There was an error rendering this rich post.

  • x00, thanks, but that's what I'm referring to when I say: it seems like it's the line break at the start of the RSS causing this

    I just don't know what file to edit to remove the blank line, mainly because I don't know what file generates the RSS. Do you know?

  • it is rss.master

    but more likely you have either transfer the files wrong such as in binary format/ with BOM or some content is being output before then.

    If you have not modified the master before it is unlikely to been changed.

    it would have
    <?php echo '<?xml version="1.0" encoding="utf-8"?>'; ?> first thing

    at the top. First thins is to disable plugin, and use default theme to rule out any of those.

    grep is your friend.

  • also get it validated here

    grep is your friend.

  • I tried the original theme, no fix. I decided to go through all my plugins again, as you suggest, and as it turns out, it was the IgnoreUser plugin which broke the RSS. I must have missed disabling it the first time around. I'll make a comment on that plugin to let people know.

    Thanks for your help all.

  • no worries.

    grep is your friend.

Sign In or Register to comment.