Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Google sign in problem and facebook log in

JuliverJuliver New
edited August 2012 in Vanilla 2.0 - 2.8

When ever ill try to log in using a google account, a new pop up window is display and it only show my main site which been linked to my vanilla forum and no such login things shown or whatsoever that is somehow related to google sign in. please see the screenshot below.

Uploaded with

When i try to log in using a facebook account and after i give access or authorize my vanilla forum, it doesnt successfully redirect nor like it was successfully completed the login instead it show a login things like it ask for a email and a username and a red box with a text on it saying "UniqueID is required", just take a look to the image below, that is the one will show after you hit authorize or grant access to the fb application.

Uploaded with

hope someone here around could help me on this or atleast point out whats wrong, thank you.


  • I'm having the same problem. Hopefully we can find a fix

  • My problem was not the same, but similar in nature, in that both Google and OpenID are not working for me. I do not get the same error messages you do, however.

    You may wish to go back into your Facebook app settings and see if something is awry there. I originally had an issue with Facebook login, but I found a solution with a bit of google searching and solved it!

  • I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.