Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

404 Not Found in popup notifications (admin and frontend)

OlafKSOlafKS New
edited August 2012 in Vanilla 2.0 - 2.8

I have a strange problem - popup notification returns error 404.
using nginx + pfpfcgi with this nginx config -
it looks like this, for example

Will appreciate any help


  • Everything works ok, except pop ups

  • As say google chrome, url of 404 file is
    I don't have this folder

    anybody, help, please :)

  • Really need help. :( I can not find where the problem is. any ideas?

  • peregrineperegrine MVP
    edited September 2012

    I don't have any answer since I don't use nginx - but you might get more help if you provide your version of vanilla and possibly the theme you are using.

    I believe it refers to (unless I am corrected)


    public function Inform() {


    notifications is the controller - inform is the function

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • OlafKSOlafKS New
    edited September 2012

    I will try to look at class.notificationscontroller.php, but i don't think that I'll find there anything - I'm designer, not programmer :( just hope that somebody had this problem already, and solved it.

    Version with any theme (now using default).
    all messages are displayed correctly (for ex. "Draft saved...") except the first one. I even don't know, what should be in this message. It does not dissapears itself, I need to close it manually. Could this be a message about new unread posts for example?

    don't know if it is important - I have imported data from simple:press

  • maybe also important - this notification appears both at frontend and in dashboard

  • Found answer :)
    just need to delete or comment two lines in config
    location /dashboard/notifications/inform { access_log off; log_not_found off; }
    location /settings/analyticstick.json { access_log off; log_not_found off; }

Sign In or Register to comment.