HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Only for Vanilla 2.1a?

This discussion is related to the CloudflareSupport addon.
edited September 2012 in Vanilla 2.0 - 2.8

i've tried basic troubleshooting since im using the latest version of vanilla by removing line 22:
'RequiredApplications' => array('Vanilla' => '2.1a'),

somehow i get another fatal error which i could not figure out:
Call to unknown method 'Gdn_Request->RemoteAddress'

can someone help ?

Comments

  • TimTim Operations Vanilla Staff

    I've uploaded a new version. Try that.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • still the same @Tim my version: Version 2.0.18.4
    ive downloaded cloudflaresupport-plugin-1-2

  • TimTim Operations Vanilla Staff

    What's the error you're getting?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • i've checked the codes somehow it's not changed:
    LINE 23: 'RequiredApplications' => array('Vanilla' => '2.1a'),

    also i get exactly the same error above: 'Gdn_Request->RemoteAddress'

    when i remove the line since' it's not built for 2.0.18.4

  • I also get the following "error":

    CloudflareSupport is missing the following requirement(s): Vanilla 2.1a.

    I'm editing the file myself to make it work. Thanks for the plugin.

    -k0nsl

  • Okay, just edited my "class.cloudflaresupport.plugin.php" but I get the same error as the other folks:

    Call to unknown method 'Gdn_Request->RemoteAddress'

    I'm not sure how to fix this yet. Does the author know how to make it compatible with Vanilla 2.0?

    -k0nsl

  • @k0nsl you got that since you already have cloudflare on your server or your vanilla is already running with cloudflare.

Sign In or Register to comment.