Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla comments integration not showing on Wordpress

OnlyAnExcuseOnlyAnExcuse ✭✭
edited September 2012 in Vanilla 2.0 - 2.8

I've run into an issue with this. Firstly, I've been working on a replacement blog for the one we currently have, so the Wordpress install is less than a week old. I've also installed a fresh Vanilla 2.1a from GitHub (as of 2 hours ago) and transferred the database to a new one using the porter.

However, i'm running into a problem.

The Vanilla Comments system isn't working on Wordpress. It is appearing in place of WP comments, but only the "progress animation" appears for a few seconds, then the only thing which displays is the footer of the Vanilla Comments area.

I've checked on Firebug, it isn't hidden behind the post anywhere, nor is it posting a new thread in the forum (i've changed the target category too, but to no avail). I've also reverted to TwentyTen to see if the problem was theme related, but the same issue cropped up there.

Here's how it looks: (this shows the footer, with "comments by Vanilla" logo. The light-blue is it highlighted in Firebug) (this shows the progress animation which appears as comments "load")

Is there a solution or would I have to edit the Wordpress theme files and add it manually?


  • Giving this a bump as it only had one view, and problem still persists.

  • Bumping unashamedly.

  • OnlyAnExcuseOnlyAnExcuse ✭✭
    edited October 2012

    I've tested this with a fresh Vanilla 2.1 install (2.1a27) and Wordpress 3.4.2 and it seems the plugin's comments integration won't work - as shown in the screens above. Here's a link to see the problem directly

    I'll report the issue on the Wordpress plugin page. Will there be an update to the plugin to coincide with the Beta release?

  • Feel like an utter tool. Sat and tried this with two wordpress installs and two vanilla ones.

    It turns out it's actually the Open Graph plugin which conflicts. I've removed it, and now it works.

    This took me weeks to work out and the simplest way to fix it was the answer. Feels great now I know it's working, but feel daft all the same that I didn't disable/re-enable plugins to check...

  • Erm, glad that you found a working solution but I only uploaded the OpenGraph plugin on October 3. Are you sure, this is what caused the problem?

  • OnlyAnExcuseOnlyAnExcuse ✭✭
    edited October 2012

    Nope. It seemed removing that plugin solved it. When I reactivated it, it stopped working.

    So I thought that was that, but no. I have a blog post here with comments already working:

    And here's one I made today. Comments don't work, same issue I always had.

    So, i'm still none the wiser as to why the thing is failing. What's worse, is it did work and now it won't. It seems it's embedding comment threads already on the forum (which it wouldn't before) but it won't start a new comments thread ON the forum and embed it into the page.

  • Yea ok. That's really weird though. I have no idea as to why it is working on some pages and not on others. Can you try turning the bonk bug report on: ?

  • OnlyAnExcuseOnlyAnExcuse ✭✭
    edited October 2012

    Added the line to config and refreshing the forum index/topic pages to no avail. I've read there's a few problems with the pagelines Wordpress theme but this problem was occuring with other themes too. Just tested with Twenty Eleven, same problem, even with a new blog post.

  • Ok, you can revert that change regarding the bonk message. Can you comment out the line

    var vanilla_url = ''; // Current page's url

    just for testing. In the code I see, you don't really need this one. I might be mistaken though...

  • I'm unsure where to comment that out - that's the page that is working with comments.

    Just had to remove Pagelines. They offered a Vanilla integration which only achieved one thing - crashing my forum entirely until the theme was removed from Wordpress. Reactivating it only brought the problem back. So i've reverted back to the bootstrap-style theme I had before.

  • Oh, you are using the wordpress plugin? I don't know then as I never worked with wordpress...

  • Pagelines is frankly terrible. It force loads wordpress atop of vanilla. Which creates a massive overhead.

    I had a client with the same problem. I convinced him just to replicate the theme. The advantages you get from PL integration is pretty short lived.

    It is almost better to have a standalone version of vanilla. You can create a wordpress page with the same url, so it loads the forum.

    grep is your friend.

  • Pagelines seems to try to do too much for what it is. I wanted to throw together a tidy layout and build on it later, but I spent more time sorting problems with it than was necessary. Their support forums were a little patronising to folk experiencing similar problems too - I'm not one to slate such things but when there's a sizeable license fee for its use you'd expect something more.

    Hey-ho, back to the drawing board!

Sign In or Register to comment.