Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Jsconnect or proxy connect for single sign on?

milleja46milleja46 New
edited September 2012 in Vanilla 2.0 - 2.8

Ok I'm starting to use vanilla v2, and ran into troubles(and hope rewriting this will get the issue more attention). I want to simply put, connect vanilla to my existing Wordpress site. So I went ahead and installed embed vanilla on both ends like I saw on the main blog. No issue there in connecting to vanilla and the embed worked. The problem comes when I looked up how to connect with jsconnect on vanilla's end so I copied the stuff to either side and thought it worked. Turns out it didn't, it just hangs at trying to connect. Can anyone tell me if there's a fix for this or do I need to switch to proxy connect?

Thanks for any help in advance


  • x00x00 MVP
    edited September 2012

    your JsAuthenticateUrl isn't working, it certainly isn't jsonp

    if i put

    I would expect to get back

        "error": "invalid_client",
        "message": "Unknown client xxxx."

    not your index html.

    where did you get the details for?:


    I presume it is the vanilla-forums plugin. You are having some other feature pre-emting the sso feature on the wordpress side, either that or server rule are not right.

    It also uses a direct url like


    grep is your friend.

  • don't create duplicate topics, and be more patient next time.

    grep is your friend.

  • I did be patient, but no one answered and the topic kept getting pushed to the buttom, and I expected that it was the lack of details. But I had gone into the single sign on in the wordpress in and it told me to copy the details in it to the vanilla side. So how is it incorrect?

  • never the less wordpress is displaying a normal page, not a jsonp page for ?VFRequest=, so something is not right on that side.

    That way of doing thing is vulnerable to being filtered out, basically, it look like it is just showing the homepage.

    you can try the other plugin, for the sign on I use that and the vanilla-forums plugin for other things.

    grep is your friend.

  • Well looks like I might have to reinstall anyways or something with jsconnect on vanilla's side since trying to delete the existing wp connection in there shows a blank page(just my site's header and background) but going back to just works somehow oddly

  • Quick question, how do I use the wp vanilla connect to connect the logins?

Sign In or Register to comment.