Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Conversations application doesn't like ipv6 address

AnonymooseAnonymoose ✭✭
edited October 2012 in Feedback

Conversations Application complains when running on server using ipv6 address, despite the varchar set to 36 in database as per: http://vanillaforums.org/discussion/comment/144612/

Says: InsertIPAddress is 5 characters too long when attempting to send a message.

Comments

  • AnonymooseAnonymoose ✭✭
    edited October 2012

    Fixing by changing /applications/conversations/settings/structure.php lines
    containting:

    Line 38: ->Column('InsertIPAddress', 'varchar(15)', TRUE)

    Line 41: ->Column('UpdateIPAddress', 'varchar(15)', TRUE)

    Line 76: ->Column('InsertIPAddress', 'varchar(15)', TRUE)

    to

    Line 38: ->Column('InsertIPAddress', 'varchar(39)', TRUE)

    Line 41: ->Column('UpdateIPAddress', 'varchar(39)', TRUE)

    Line 76: ->Column('InsertIPAddress', 'varchar(39)', TRUE)

    And turning off and on the Conversations application.
    However this seems to have removed all existing conversations (from an import). Oh well.

Sign In or Register to comment.