Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Can't even install vanilla...

RadarNyanRadarNyan New
edited October 2012 in Vanilla 2.0 - 2.8

Hi everyone, I'm a rookie admin running a none-vanilla forum and want to change to Vanilla.

But I can't even start :(

This is what I've done:

  1. Download vanilla(Version 2.0.18.4) and uploaded to my VPS
  2. unziped online (using putty)
  3. access my website then I got "Fatal error: Class 'Gdn' not found in /home/wwwroot/vanilla/bootstrap.php on line 47"

Anyone can help x_x ?

I'm using a VPS running centos 6.2, nginx 1.2.4 + PHP 5.2 I already have a wordpress running perfectly.

Comments

  • Options
    RadarNyanRadarNyan New
    edited October 2012

    (can't I edit my post?)

    I've tried "chown -R www vanilla" but it didn't help :(

    (Ok I found out how to edit now.)

    And I also gave cache,conf and uploads folders 777 permissions, also didn't work.

  • Options
    KasperKasper Scholar of the Bits Copenhagen Vanilla Staff

    You should try deleting any .ini files in your cache folder - it might do the trick.

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

  • Options

    @kasperisager said:
    You should try deleting any .ini files in your cache folder - it might do the trick.

    Thanks for your reply.
    I've checked cache folder already - there isn't any .ini files but a empty file named "empty" in it.
    (Of course, It's a totally new forum.)

    Can't wait to use Vanilla - it's just great!

  • Options

    @RadarNyan said:
    3. access my website then I got "Fatal error: Class 'Gdn' not found in /home/wwwroot/vanilla/bootstrap.php on line 47"

    The most obvious question is to look for where that class 'Gdn' would be and actually look in that directory if 'Gdn' is actually there.

    Then I would do the following (work around):

    Delete all Vanilla files

    Unzip Locally

    Upload files again (different directory? Although 'vanilla' is default)

    chown -R sounds good to me, so keep that if you need it.

    There was an error rendering this rich post.

  • Options

    @UnderDog Thanks for your reply.

    I tried to delete all the vanilla files online, Unziped locally then uploaded through SFTP.
    After that I did run chown & chmod, but still get the same error.
    Also tried to rename 'vanilla' folder to another name, still didn't work for me.

    (Can't I start a new line in comment? If I press Enter once I got nothing, twice got a empty line between the two lines)

  • Options

    @UnderDog

    I‘ve got scandir disabled in my php.ini, after enable it I can see the Installer now!

    Thanks for help. Maybe add this problem to install guide?

Sign In or Register to comment.