Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Weird Edit Problem

edited March 2007 in Vanilla 1.0 Help
For some reason all of a sudden when I go to edit a conversation, it does not display the original post in the edit box. It just shows a blank box. If you try and type in something into the box it outputs the following error....

Some problems were encountered
You must enter a value for the discussion topic input.


Update:
I found this to be a problem when combined with the friendly URL extension. Not sure why this is happening since it works a'Ok here. Any ideas?

Comments

  • Options
    MarkMark Vanilla Staff
    Tell me more: What version of PHP? What version of MySQL? What operating system and version? What browser and version?
  • Options
    PHP: 4.4.2 MySQL: 4.0.17 OS: RedHat 9 (Server) XPSP2 (local) Broswer: Firerfox 1.5.0.3
  • Options
    MarkMark Vanilla Staff
    dammit.

    I fully expected this to be a PHP 5 issue.

    Okay - what version of the repository do you have?
  • Options
    edited May 2006
    i know i dled v1, but how can i check which rev i have?

    Edit: I think I have 421
  • Options
    MarkMark Vanilla Staff
    Ohhh. you got a pre-release, huh?

    I'll test out my local copy...
  • Options
    jared, if you're checking it out with SVN, try checking out afresh and watch the reported rev-no. Or are you using the pre-release zip archive?

    FWIW, Mark: I *don't* see this problem on PHP 5.05, MySQL 4.14, Firefox, Win, Rev 421. Everything fine.
  • Options
    i grabbed the pre-release through the zip archive... i just starting messing w/ svn and downloaded tortoise so i will see if i can get that up and running.
  • Options
    It works fine for me. PHP 4.3.10, MySQL 4.0.25-standard, Firefox, Win XP, Rev 421, and with the clean URLs.
  • Options
    if i were to upgrade via svn- should i upgrade everything and save my settings.php?
  • Options
    edited May 2006
    Keep your /conf/ folder, and wipe everything else. Unless you've made custom themes or something.
  • Options
    edited May 2006
    i am going to give that a shot.... crosses fingers....

    Ok I redownloaded the whole svn v.421 from lussumo.com/svn/vanilla/ and uploaded it back and is running fine... HOWEVER,

    when i enable friendly urls, the edit post function still does not work for me?
  • Options
    anyone? bueller? bueller?
  • Options
    I am experiencing this exact same problem, with the v1 pre-release. Its very annoying.
  • Options
    good. im glad im not the only one!
  • Options
    MarkMark Vanilla Staff
    I don't have time to work on Vanilla right now. Big deadline at work. I'll help when I can.
  • Options
    No worries Mark. Beat that deadline!
  • Options
    dont mean to be a pest, but does anyone have any idea as to how to resolve this?
  • Options
    TexTex
    edited March 2007
    I have the same problem as reported in 'Edit' doesn't work anymore. Enabling Friendly URLs causes edit won't work.

    Vanilla 1.1.2
    PHP 4.4.4-8
    MySQL 4.0.24
    Windows XP
    Firefox and IE
This discussion has been closed.