Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Enable HTML formatting

edited May 2006 in Vanilla 1.0 Help
Hey, just wanted to say how awesome I think this application is. I just installed it yesterday at a new forum site I'm working on and it's great.

Do have some minor questions I hope somebody here will be able to field. See at the bottom of this comment form, there's a little radio button thing that says "Format comments as () Text () Html"? How do I get that to work on mine? (I also don't seem to have that thing that says "Text-only mode is OFF (turn on)" - is that an extension? Are they somehow connected?)

I posted some HTML in a comment, and nothing happened. Samething when I tried switching it to BBcode. Sorry if this has been addressed elsewhere already. I did a search, but couldn't find anything that seemed to solve it. I am using the pre-release of version 1.

Thanks!

Comments

  • Options
    Go to Settings > Manage Extensions Enable the HTML formatter extension.
  • Options
    I'm using pre-release version 1. It doesn't come bundled with any extensions. And I don't see that extension listed in the add-ons section.

    I did, however, download the older version though, which I think does have that extension in it. Can I just drop that extension into v1? Let me check... nope. That doesn't work.

    According to readme's in other extensions, it says you have to make a unique folder inside "extensions" in this version, such as:

    /path/to/vanilla/extensions/this_extension_name/default.php

    Okay, I made a folder inside extensions called HtmlFormatter and then renamed the file to "default.php". Lets see if that works.... Okay, that extension now shows up when I go to Settings > Manage Extensions.

    BUT... it looks like it broke something along the way. When I navigate to a page where I tried using blockquotes, I get this error:
    Notice: Use of undefined constant agFORMATSTRINGFORDISPLAY - assumed 'agFORMATSTRINGFORDISPLAY' in /path/to/vanilla/extensions/HtmlFormatter/default.php on line 56
    It did, however, still apply the blockquotes in my text, so that's cool. But it also busted another extension I have "Extended Text Formatter" which turns plain text URL's into hyperlinks.

    Any thoughts on how to proceed?
  • Options
    I also tried uninstalling that and installing the Better BBCode extension instead. That seems to have solved the "undefined constant" problem, but it's still knocking my other plain text link formatter out of commission...
  • Options
    V1 doesn't bundle any extensions? Oh geez.
  • Options
    The pre-release v1 from Subversion does come with a full compliment of extensions (svn update http://lussumo.com/svn/vanilla/trunk). They are disabled by default, but can be enabled using the Admin screens.
  • Options
    Yeah but the prerelease zip (and all future releases, i believe) dont come bundled with any (it'd somewhat defeat the point in many ways) since the advent of the addons directory so people can easily see whats available. The html formatter, however, is not on the addons system yet (i believe) cause it's SirNot's and he hasnt put it on. You can still grab it off the SVN, however, and that's probably easier than hacking around with <v1 stuff.
  • Options
    So... what exactly do I need to do to make both the HTML formatter AND the url formatter work? Or, else the BBcode formatter and the url formatter? Even better, all three?
This discussion has been closed.