Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Upgrade to Version 2.1a27

Hi Everyone,

I upgraded to the newest version and I think I messed up a little. The previous users do seem to appear but

  • all discussions are gone.
  • not all plugins are recognized (it shows 16 plugins in the web interface vs 20 plugins in the folder)
    One of the plugins that does not show up is the updated Facebook.

How can I fix this? At least the plugin issue. The post I can restore manually.

Thanks

Comments

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @solve

    2.1 is still in development.

    It is not meant for production sites yet (except in a 'use at your own risk' way.)

    You'd be better off doing a clean install of the stable 2.0.18 version and pointing your db at that, imo.

  • Options

    Hi,

    Thanks for the suggestion. However I like to experiment, especially to learn more about Vanilla in the process.

    Is there anything I can do to reset the plug-in system? I've already had a look trough the config and MYSQL but I can't figure out why these few plugins won't show up in the web-interface.

    Thanks in advance

  • Options
    KasperKasper Scholar of the Bits Copenhagen Vanilla Staff
    edited October 2012

    @solve said:
    Hi,

    Thanks for the suggestion. However I like to experiment, especially to learn more about Vanilla in the process.

    Is there anything I can do to reset the plug-in system? I've already had a look trough the config and MYSQL but I can't figure out why these few plugins won't show up in the web-interface.

    Thanks in advance

    Some of the plugins are now hidden and can be activated through new menus. This is the case for e.g. the Facebook and Twitter plugins - these can now be activated and configured through the new "Social" menu in the dashboard. Other "statically" active plugins like HTMLawed won't show up at all as it's just a utility used by Vanilla to filter out potentially malicious code from discussions and comments.

    By the way, if you just stick to the master branch from Github the code will be perfectly fine to use - all hosted forums run on this codebase. It's the development branch that contains the "use at your own risk"-code.

    Kasper Kronborg Isager (kasperisager) | Freelance Developer @Vanilla | Hit me up: Google Mail or Vanilla Mail | Find me on GitHub

  • Options

    @kasperisager said:
    By the way, if you just stick to the master branch from Github the code will be perfectly fine to use - all hosted forums run on this codebase. It's the development branch that contains the "use at your own risk"-code.

    Thank you @kasperisager for this little piece of information.

  • Options

    @solve please make a backup of the files of your current situation. We might need it during testing of the upgrade system.
    For the rest, just follow kasperisager's advice :-) Tip is : backup, backup, backup.

    There was an error rendering this rich post.

Sign In or Register to comment.