Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Premission problem with Rewrite Urls on xampp

When I turn on Vanilla Rewrite Urls it working fine, however, when user (that is already log in) try to post a comment, Vanilla disconnect alter with "You don't have permission to do that." and then disconnect the user.

When I turn off Rewrite Urls, everything working fine.

any idea?


  • Options

    maybe your .htaccess is not set up correctly.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    don't think it's .access issue, cuz links (to pages, discuss and so) are working fine.

  • Options

    @erez said:
    don't think it's .access issue, cuz links (to pages, discuss and so) are working fine.

    You have to figure out with which actions your user get the message "You don't have permission to do that" Then go into the language definition files and find the exact same text.
    Now, in the source code of Vanilla find the text that you just found in the language definition files.
    It's a permission error, for sure.
    Last you need to look in the sourcecode for that permission error that shows up with the action your user did.
    When you've figured that out, you can conclude by looking at the sourcecode what is wrong, which things are set up wrong, etc.

    There was an error rendering this rich post.

  • Options

    hi underdog,
    thanks for debugging advice. I just was hope someone had faced it before...

Sign In or Register to comment.