Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Turning off Magic Quotes - fine on one install, not on another on same server

OnlyAnExcuseOnlyAnExcuse ✭✭
edited November 2012 in Vanilla 2.0 - 2.2

Hi guys, I've had a look at threads detailing how to turn off Magic Quotes on my server. And I have used the .htaccess method with success. Until recently, that is.

In my server's root folder, there's an .htaccess file with the following lines I added to turn this feature off:

php_value magic_quotes 0
php_flag magic_quotes off
php_value magic_quotes_gpc 0
php_flag magic_quotes_gpc off

This has ensured no stray backslashes are output on Vanilla and Wordpress.

Until a few days ago. Wordpress itself doesn't have any issues. I have my forum in the /forums subdirectory and magic quotes never caused any problems with it until a few days ago either.

I also have a /vanilla subdirectory, and it is fine - no backslashes are added after '''.

http://forum.onlyanexcuse.com/discussion/1586/ballon-dor-shortlist#latest - example on site i'm having magic quote issues with.

http://onlyanexcuse.com/vanilla/discussion/1/testing-forum-and-blog-comments-onlyanexcuse#latest - test install example which doesn't suffer same problems.

I've went through the process of adding the above lines to .htaccess in my forum's root to no avail. The test install doesn't have it in its .htaccess.

I've removed every plugin and changed the theme to Bitter Sweet, +Baseline and Embed Friendly (standard 2.1 themes). Still backslashes are being applied in posts made.

I've contacted my host, who've said it is a problem with the script i'm using and said that the .htaccess changes are fine - i'm using a reseller hosting package and i've turned off magic quotes on a couple of sites with no issues until now. I've updated to 2.1a31 today in a bid to try and sort it that way but to no avail.

Anyone any ideas? Bear in mind I can't turn it off in php.ini, and adding custom php.ini files to relevant folders has no effect.

Comments

Sign In or Register to comment.