Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Change Email Content

24

Answers

  • Yep I copy and pasted from lines 1-14.

    I figured lines 15-30 wasn't supposed to be code for me to include...

  • ok can you post the contents of what is in

    cache/locale_map.ini

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • [en-CA]
    0 = "/home/thecashl/public_html/vanilla/applications/dashboard/locale/en-CA/definitions.php"
    1 = "/home/thecashl/public_html/vanilla/applications/conversations/locale/en-CA/definitions.php"
    2 = "/home/thecashl/public_html/vanilla/applications/vanilla/locale/en-CA/definitions.php"
    3 = "/home/thecashl/public_html/vanilla/conf/locale.php"
    [Embed-Locale]
    0 = "/home/thecashl/public_html/vanilla/locales/Embed-Locale/definitions.php"
    1 = "/home/thecashl/public_html/vanilla/locales/Embed-Locale/other_definitions.php"
    2 = "/home/thecashl/public_html/vanilla/conf/locale.php"

  • [en-CA]
    0 = "/home/thecashl/public_html/vanilla/applications/dashboard/locale/en-CA/definitions.php"
    1 = "/home/thecashl/public_html/vanilla/applications/conversations/locale/en-CA/definitions.php"
    2 = "/home/thecashl/public_html/vanilla/applications/vanilla/locale/en-CA/definitions.php"
    3 = "/home/thecashl/public_html/vanilla/conf/locale.php"
    [Embed-Locale]
    0 = "/home/thecashl/public_html/vanilla/locales/Embed-Locale/definitions.php"
    1 = "/home/thecashl/public_html/vanilla/locales/Embed-Locale/other_definitions.php"
    2 = "/home/thecashl/public_html/vanilla/conf/locale.php"
    
  • peregrineperegrine MVP
    edited November 2012

    delete your Embed-Locale and copy it somewhere else outside of locales (if you want to save it.)

    and delete the file
    cache/locale_map.ini

    after you do this.
    try the email

    then if it doesn't work show a sample of the email confirm.
    and show me the new contents of cache/locale_map.ini

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    thecashbag
  • Done. But no change.

  • delete your Embed-Locale and copy it somewhere else outside of locales (if you want to save it.)

    and delete the file cache/locale_map.ini

    after you do this. try the email

    then if it doesn't work show a sample of the email confirm. and show me the new contents of cache/locale_map.ini

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • New locale_map.ini

    [en-CA]
    0 = "/home/thecashl/public_html/vanilla/applications/dashboard/locale/en-CA/definitions.php"
    1 = "/home/thecashl/public_html/vanilla/applications/conversations/locale/en-CA/definitions.php"
    2 = "/home/thecashl/public_html/vanilla/applications/vanilla/locale/en-CA/definitions.php"
    3 = "/home/thecashl/public_html/vanilla/locales/skeleton/definitions.php"
    4 = "/home/thecashl/public_html/vanilla/locales/skeleton/other_definitions.php"
    5 = "/home/thecashl/public_html/vanilla/conf/locale.php"
    

    Hello ttt!

    You have successfully registered for an account at The Cash Lab forum. Here is your information:
    Username: ttt
    Email: [email protected]
    Thanks for joining. You can access the forum at thecashlab.com/forum/.

    You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/28/QA5RHBE4

    Have a great day!

  • its reading the locale show me exactly what you want the difference to be.

    also disable skeleton locales in your dashboard - you are not using it now.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • also you might want to edit and delete your e-mail address above in the previous post so you don't get spam.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Skeleton locale disabled. Cannot change email unfortunately... 15 min limit on editing posts.

    It's the confirmation link that doesn't get updated. The whole message should be like this:

    Hello ttt!

    You have successfully registered for an account at The Cash Lab forum. Here is your information: Username: ttt Email: [email protected] Thanks for joining. You can access the forum at thecashlab.com/forum/.

    You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: http://thecashlab.com/forum/#/entry/emailconfirm/28/QA5RHBE4

    Have a great day!

  • So I think it's part of the locale that is not working for me:

    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: www.thecashlab.com/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}';

    And I actually think "www.thecashlab.com/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}" should be "www.thecashlab.com/forum/#/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}" for it to work corectly.

    But either way $Definition['EmailConfirmEmail'] does not get updated for some reason

  • I don't follow you --

    But either way $Definition['EmailConfirmEmail'] does not get updated for some reason

    can you be clearer - the link is obviously changed. we just need to get the right one.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • The link that gets sent in the default email is this:
    http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/29/0RC3MQSF

    When following that it takes you to the vallia forum that is not embeded.

    It needs to be a link like this so that it takes you to an embeded forum:
    http://thecashlab.com/forum/#/entry/emailconfirm/28/QA5RHBE4

    To get it to appear like that I think the code should be like this:
    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: www.thecashlab.com/forum/#/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}';

    But no matter what I put for that code, the link does not change. It always stays the default link (http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/29/0RC3MQSF). Even if I change that code like this:

    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: hhhhhhhhhhheeeeeeeeeeellllllllloooooooooooo';

    It will still look like this in the email with the default text and link:
    You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/28/QA5RHBE4

  • Sorry will re-post to make easier to read:

    The link that gets sent in the default email is this:
    http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/29/0RC3MQSF

    When following that it takes you to the vallia forum that is not embeded.

    It needs to be a link like this so that it takes you to an embeded forum:
    http://thecashlab.com/forum/#/entry/emailconfirm/28/QA5RHBE4

    To get it to appear like that I think the code should be like this:
    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: www.thecashlab.com/forum/#/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}';

    But no matter what I put for that code, the link does not change. It always stays the default link (http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/29/0RC3MQSF). Even if I change that code like this:

    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: hhhhhhhhhhheeeeeeeeeeellllllllloooooooooooo';

    It will still look like this in the email with the default text and link:

    You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: http://thecashlab.com/vanilla/index.php?p=/entry/emailconfirm/28/QA5RHBE4

  • Haha ok that is harder to read... sorry

  • yes you need to change the confirm link

    yourforumlocation{User.UserID,rawurlencode}/{EmailKey,rawurlencode}';

    if it is located in www.thecashlab.com/forum/

    $Definition['EmailConfirmEmail'] = 'You need to confirm your email address before you can continue. Please confirm your email address by clicking on the following link: www.thecashlab.com/forum/{User.UserID,rawurlencode}/{EmailKey,rawurlencode}';

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes I have tried that. It but it does not work. It keeps displaying the original text and link. For some reason the local for $Definition['EmailConfirmEmail'] will not update to whatever I set it to. It keeps showing the original $Definition['EmailConfirmEmail'].

  • try changing in conf

    don't lnow if that will fix it.

    $Configuration['Garden']['VanillaUrl'] = "http://thecashlab.com/forum/";

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • now I understand your problem. :). I was confused you said the link does not change - so I was assuming your locale doesn't work based on some of your answers. But your locale is read correcly - you just have a problem with the specific link (embedded vs. unembedded). I don't know the answer.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.