Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

No styling for new 2.1a32 install

maxchomaxcho New
edited November 2012 in Vanilla 2.0 - 2.8

I installed the latest 2.1a32 downloaded from Github

But there's no styling for the entire site. The stylesheet refers to '/utility/css/style/style-b92f6518.css', which does not exist. I don't how this happened.

Please checkout the issue at snip

Tagged:

Best Answer

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    The utility/css/style-xxx.css is indeed a new way of combining styles. I'm guessing that this will be an option rather than the default when we release 2.1.

Answers

  • If you install a normal Vanilla (2.0.18.4) and not the alpha version, the CSS file is located in ... dashboard? (guys, help).
    So point that stylesheet in your theme to that location. Will you see styles now?

    There was an error rendering this rich post.

  • peregrineperegrine MVP
    edited November 2012

    . duplicate deleted

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited November 2012

    It still reads the css from your

    themes/nameoftheme/custom.css
    and
    applications/dashboard/design/style.css

    my guess is it combines the two and it shows up as looking like this...
    /utility/css/style/style-xxxxxxx.css

    with xxxxx being some number. that is a combination of the two.

    try deleting the .ini files if any in your /cache/Smarty/cache

    and possibly

    any files that look something like this in cache/Smarty/compile

    vanilla^%%D5^D5D^D5D54F30%%default.master.tpl.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine said:
    It still reads the css from your

    themes/nameoftheme/custom.css
    and
    applications/dashboard/design/style.css

    my guess is it combines the two and it shows up as looking like this...
    /utility/css/style/style-xxxxxxx.css

    with xxxxx being some number. that is a combination of the two.

    try deleting the .ini files if any in your /cache/Smarty/cache

    and possibly

    any files that look something like this in cache/Smarty/compile

    vanilla^%%D5^D5D^D5D54F30%%default.master.tpl.php

    I tried above, but it didn't work. I guess the 404 error has something to do with the nginx configuration.

    Currently, I'm using location / { try_files $uri $uri/ /index.php?p=$uri&$args; }

    But everything go through the link "mysite.com/utility/thumbnail/xxx" or "mysite.com/utility/css/xxx" gets the 404 error.

    @Todd could we have an official nginx configuration?

  • peregrineperegrine MVP
    edited November 2012

    A very wild guess - but does this help.

    changing TRUE to FALSE or if it is FALSE changing to TRUE

    in conf/config.php

    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['RewriteUrls'] = FALSE;
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine said:
    A very wild guess - but does this help.

    changing TRUE to FALSE or if it is FALSE changing to TRUE

    in conf/config.php

    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['RewriteUrls'] = FALSE;
    

    It's weird that after I done the change. All the other urls turned ugly only the "utility" link stays. So still not work.

  • @peregrine said:
    A very wild guess - but does this help.

    changing TRUE to FALSE or if it is FALSE changing to TRUE

    in conf/config.php

    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['RewriteUrls'] = FALSE;
    

    Silly me. It it about nginx configuration indeed. But not the rewrite rule. Instead, it's about the additional rule I learned from https://github.com/perusio/drupal-with-nginx

    so after I removed

    ## Disable access logs for robots.txt.
    location = /robots.txt {
        access_log off;
        allow all;
        log_not_found off;
    }
    

    and

    ## All static files will be served directly.
    location ~* ^.+\.(?:css|gif|htc|ico|js|jpe?g|png|swf)$ {
        access_log        off;
        expires           max;
        ## No need to bleed constant updates. Send the all shebang in one
        ## fell swoop.
        tcp_nodelay off;
        ## Set the OS file cache.
        open_file_cache max=1000 inactive=120s;
        open_file_cache_valid 45s;
        open_file_cache_min_uses 2;
        open_file_cache_errors off;
    }
    

    everything's fine now.

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    The utility/css/style-xxx.css is indeed a new way of combining styles. I'm guessing that this will be an option rather than the default when we release 2.1.

  • Well I borrow this thread a little, bec i have the same problem here. I'm Using apache and I have no styling at all. And when i'm looking at the site using firebug I have no stylecheet at all.

  • @zar3x maxcho's problem was directly related to nginx configuration, I think it s better when people don't borrow threads where there is no clear connection. Best start a new topic.

    grep is your friend.

  • @x00 okey I will do

  • edited November 2012

    my mistake, sorry.

  • wkauawkaua New
    edited March 2013

    use this config in nginx

    location / {        
        try_files $uri $uri/ @forum;
    }
    
    location @forum {
        rewrite ^ /index.php?p=$uri&$args last;
    }
    
    location ~* \.(ico|css|js|gif|jpe?g|png)(\?[0-9]+)?$ {
        expires 360d;
        access_log off;
        log_not_found off;
        try_files $uri @forum;
        break;
    }
    

    and stay $Configuration['Garden']['RewriteUrls'] = TRUE;

Sign In or Register to comment.